Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60915 - [composer] composer doesn't find zip php extension but it's is installed

Attached to Project: Arch Linux
Opened by patrick (potomac) - Monday, 26 November 2018, 23:00 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 26 November 2018, 23:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I have installed composer, then I properly configured /etc/pĥp/php.ini for php extensions needed by composer,

then I tried to install lavarel :

composer global require "laravel/installer"

but it fails because composer claims that it doesn't find zip php extension, but the zip extension is installed and enabled in /etc/php/php.ini (I check with "phpinfo()",

the log message of composer :

"Changed current directory to /home/cesar/.config/composer
Using version ^2.0 for laravel/installer
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- laravel/installer v2.0.1 requires ext-zip * -> the requested PHP extension zip is missing from your system.
- laravel/installer v2.0.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.
- Installation request for laravel/installer ^2.0 -> satisfiable by laravel/installer[v2.0.0, v2.0.1].

To enable extensions, verify that they are enabled in your .ini files:
- /etc/php/php.ini
- /etc/php/conf.d/apcu.ini
- /etc/php/conf.d/imagick.ini
- /etc/php/conf.d/xdebug.ini
You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

Installation failed, reverting ./composer.json to its original content."

I think there is something wrong in the archlinux composer package, zip extension is already installed and working, so why composer doesn't detect this zip extension ?


Additional info:
* package version(s) composer 1.7.3-1

* config and/or log files etc.


Steps to reproduce:

- install apache, php and composer 1.7.3-1
- configure php.ini by enabling zip extension
- install laravel with composer : composer global require "laravel/installer"
- you will have an error message, composer will not find zip extension, despite it's enabled in /etc/php/php.ini
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 26 November 2018, 23:22 GMT
Reason for closing:  Works for me
Additional comments about closing:  You already have a help thread at https://bbs.archlinux.org/viewtopic.php? id=242255

Loading...