Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60900 - [mkinitcpio] linux 4.19.2 breaks sd-vconsole in initramfs

Attached to Project: Arch Linux
Opened by Gunnar Bretthauer (Taijian) - Friday, 23 November 2018, 18:38 GMT
Last edited by Dave Reisner (falconindy) - Monday, 10 December 2018, 01:56 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After upgrade to kernel 4.19.x my initramfs generated via mkinitcpio no longer contains a working keymap matching my physical keyboard. The initramfs' for both linux-hardened (4.18.20) and linux-lts (4.14.82) do have working keymaps even in the initramfs, generated from the same mkinitcpio.conf.
I need the keymap in the initramfs because I boot off of an encrypted lvm, so if the keymap matches my physical keyboard, then muscle memory can do the typing for me. But since the keymap in the 4.19.2 initramfs is the US one, I now have to think in order to type in my passphrase. Once I get to GDM, the keymapping works again, it's just the plymouth-login that does not work.

Additional info:
* package version(s)
mkinitcpio 25-1
linux-4.19.2 (does not work)
linux-hardened-4.18.20 (works)
linux-lts-4.14.82 (works)
plymouth-git

* config and/or log files etc.
mkinitcpio.conf attached

Steps to reproduce:

Install kernel linux-4.19.2
generate initramfs
reboot
This task depends upon

Closed by  Dave Reisner (falconindy)
Monday, 10 December 2018, 01:56 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Bug appears to be in Plymouth, not mkinitcpio.
Comment by Dave Reisner (falconindy) - Sunday, 09 December 2018, 20:03 GMT
You mention "plymouth-login" which I think is what you're suggesting takes your password in the initramfs. Can you reproduce this without plymouth? I'm not interested in supporting packages from the AUR.
Comment by Gunnar Bretthauer (Taijian) - Sunday, 09 December 2018, 23:03 GMT
OK, sorry for not checking this first. I can indeed confirm now that it seems to be a bug with plymouth. Without plymouth decryption works as expected, with plymouth something breaks.

I'll take this over to the AUR/plymouth's bugtracker.
Sorry for wasting your time!
Comment by Dave Reisner (falconindy) - Monday, 10 December 2018, 01:56 GMT
No problem. At least you've got it narrowed down a bit more.

Loading...