Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60851 - /usr/lib/libKF5KCMUtils.so.5: undefined symbol: _ZN15KPageWidgetItem16setHeaderVisibleEb

Attached to Project: Arch Linux
Opened by David (davlucasgmail.com) - Sunday, 18 November 2018, 11:49 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 18 November 2018, 11:55 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
kcumutils does not work , so it means it's impossible to access tools such as systemsettings5, dolphin or kinfocenter, all other kde app are working smoothly

Additional info:
* kcmutils 5.52.0-1
* kinfocenter 5.14.3-1
* systemsettings 5.14.3-1
* konqueror 18.11.80-1

* config and/or log files etc.
% kinfocenter kinfocenter: symbol lookup error: /usr/lib/libKF5KCMUtils.so.5: undefined symbol: _ZN15KPageWidgetItem16setHeaderVisibleEb

strace output shows:
writev(2, [{iov_base="kinfocenter", iov_len=11}, {iov_base=": ", iov_len=2}, {iov_base="symbol lookup error", iov_len=19}, {iov_base=": ", iov_len=2}, {iov_base="/usr/lib/libKF5KCMUtils.so.5", iov_len=28}, {iov_base=": ", iov_len=2}, {iov_base="undefined symbol: _ZN15KPageWidg"..., iov_len=58}, {iov_base="", iov_len=0}, {iov_base="", iov_len=0}, {iov_base="\n", iov_len=1}], 10kinfocenter: symbol lookup error: /usr/lib/libKF5KCMUtils.so.5: undefined symbol: _ZN15KPageWidgetItem16setHeaderVisibleEb



% nm /usr/lib/libKF5KCMUtils.so.5
nm: /usr/lib/libKF5KCMUtils.so.5: aucun symbole


# ls -l libKF5KCMUtils.so*
lrwxrwxrwx 1 root root 19 7 nov. 15:07 libKF5KCMUtils.so -> libKF5KCMUtils.so.5
lrwxrwxrwx 1 root root 24 7 nov. 15:07 libKF5KCMUtils.so.5 -> libKF5KCMUtils.so.5.52.0
-rwxr-xr-x 1 root root 333576 7 nov. 15:07 libKF5KCMUtils.so.5.52.0




Steps to reproduce:

login Plasma,
run systemsettings5

kde great teams probably forget to provide upgrade for kcmutils yet , so will probably be corrected next release, but it may come from other issue, that's why i created this ticket
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 18 November 2018, 11:55 GMT
Reason for closing:  Not a bug
Additional comments about closing:  You are using an unsupported kwidgetsaddons package

Loading...