Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60821 - [sdl_gfx] 2.0.26-2 package contains libSDL_gfx.so.15.9.1 instead of libSDL_gfx.so.16.9.1

Attached to Project: Arch Linux
Opened by Brian BIdulock (bidulock) - Friday, 16 November 2018, 04:47 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 18 November 2018, 07:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Package sdl_gfx 2.0.26-2 contains the following:

$> yaourt -Qil sdl_gfx

Name : sdl_gfx
Version : 2.0.26-2
Description : SDL graphics drawing primitives and other support functions
Architecture : x86_64
URL : http://www.ferzkopp.net/wordpress/2016/01/02/sdl_gfx-sdl2_gfx/
Licenses : LGPL
Groups : None
Provides : None
Depends On : sdl
Optional Deps : None
Required By : perl-sdl
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 178.00 KiB
Packager : Evangelos Foutras <evangelos@foutrelis.com>
Build Date : Fri 09 Nov 2018 05:23:43 PM MST
Install Date : Wed 14 Nov 2018 09:40:45 AM MST
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

sdl_gfx /usr/
sdl_gfx /usr/include/
sdl_gfx /usr/include/SDL/
sdl_gfx /usr/include/SDL/SDL_framerate.h
sdl_gfx /usr/include/SDL/SDL_gfxBlitFunc.h
sdl_gfx /usr/include/SDL/SDL_gfxPrimitives.h
sdl_gfx /usr/include/SDL/SDL_gfxPrimitives_font.h
sdl_gfx /usr/include/SDL/SDL_imageFilter.h
sdl_gfx /usr/include/SDL/SDL_rotozoom.h
sdl_gfx /usr/lib/
sdl_gfx /usr/lib/libSDL_gfx.so
sdl_gfx /usr/lib/libSDL_gfx.so.15
sdl_gfx /usr/lib/libSDL_gfx.so.15.9.1
sdl_gfx /usr/lib/pkgconfig/
sdl_gfx /usr/lib/pkgconfig/SDL_gfx.pc

However, the perl-sdl links with libSDL_gfx.so.16:

$> ldd /usr/lib/perl5/5.28/vendor_perl/auto/SDL/GFX/Primitivies.so

linux-vdso.so.1 (0x00007fff743af000)
libSDL-1.2.so.0 => /usr/lib64/libSDL-1.2.so.0 (0x00007ff94585f000)
libpthread.so.0 => /usr/lib64/libpthread.so.0 (0x00007ff94583e000)
libSDL_gfx.so.16 => not found
libc.so.6 => /usr/lib64/libc.so.6 (0x00007ff945604000)
libm.so.6 => /usr/lib64/libm.so.6 (0x00007ff94547f000)
libdl.so.2 => /usr/lib64/libdl.so.2 (0x00007ff94547a000)
/usr/lib64/ld-linux-x86-64.so.2 (0x00007ff945916000)

$> yaourt -Qi perl-sdl

Name : perl-sdl
Version : 2.548-1
Description : Simple DirectMedia Layer for Perl
Architecture : x86_64
URL : http://sdl.perl.org
Licenses : LGPL
Groups : None
Provides : sdl_perl=2.548
Depends On : perl-alien-sdl perl-tie-simple sdl_net sdl_ttf sdl_image sdl_mixer sdl_gfx sdl_pango smpeg
Optional Deps : None
Required By : frozen-bubble
Optional For : None
Conflicts With : sdl_perl
Replaces : sdl_perl
Installed Size : 2.40 MiB
Packager : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Build Date : Sat 27 Oct 2018 07:36:27 AM MDT
Install Date : Thu 15 Nov 2018 09:18:54 PM MST
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Which was not a problem in sdl_gfx 2.0.26-1.

If I rebuild the sdl_gfx package from the PKGBUILD in a clean chroot I get:

$> yaourt -Qilp sdl_gfx-2.0.26-2-x86_64.pkg.tar.xz

Name : sdl_gfx
Version : 2.0.26-2
Description : SDL graphics drawing primitives and other support functions
Architecture : x86_64
URL : http://www.ferzkopp.net/wordpress/2016/01/02/sdl_gfx-sdl2_gfx/
Licenses : LGPL
Groups : None
Provides : None
Depends On : sdl
Optional Deps : None
Conflicts With : None
Replaces : None
Compressed Size : 45.81 KiB
Installed Size : 202.00 KiB
Packager : Brian Bidulock <bidulock@openss7.org>
Build Date : Thu 15 Nov 2018 09:31:50 PM MST
Install Script : No
Validated By : None
Signatures : None

sdl_gfx /usr/
sdl_gfx /usr/include/
sdl_gfx /usr/include/SDL/
sdl_gfx /usr/include/SDL/SDL_framerate.h
sdl_gfx /usr/include/SDL/SDL_gfxBlitFunc.h
sdl_gfx /usr/include/SDL/SDL_gfxPrimitives.h
sdl_gfx /usr/include/SDL/SDL_gfxPrimitives_font.h
sdl_gfx /usr/include/SDL/SDL_imageFilter.h
sdl_gfx /usr/include/SDL/SDL_rotozoom.h
sdl_gfx /usr/lib/
sdl_gfx /usr/lib/libSDL_gfx.so
sdl_gfx /usr/lib/libSDL_gfx.so.16
sdl_gfx /usr/lib/libSDL_gfx.so.16.9.1
sdl_gfx /usr/lib/pkgconfig/
sdl_gfx /usr/lib/pkgconfig/SDL_gfx.pc

I think the package needs to be rebuilt.

Additional info:
* package version(s): 2.0.26-2
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 18 November 2018, 07:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  sdl_gfx 2.0.26-3

Loading...