Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60807 - [nvidia-lts] needs rebuild for linux-lts 4.14.80-1

Attached to Project: Arch Linux
Opened by loqs (loqs) - Wednesday, 14 November 2018, 16:32 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 15 November 2018, 08:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
There is a symbol mismatch between linux-lts 4.14.80 and nvidia-lts 1:410.73-1

Additional info:
* nvidia-lts 1:410.73-1
* linux-lts 4.14.80-1
* https://bbs.archlinux.org/viewtopic.php?id=241902

[ 6.200782] nvidia: module license 'NVIDIA' taints kernel.
[ 6.200784] Disabling lock debugging due to kernel taint
[ 6.205249] nvidia: disagrees about version of symbol wake_up_process
[ 6.205251] nvidia: Unknown symbol wake_up_process (err -22)

Steps to reproduce:
* Install nvidia-lts 1:410.73-1 and linux-lts 4.14.80-1
* Boot into linux-lts 4.14.80-1
* modprobe nvidia then check module has failed to load and symbol mismatch output is in dmesg
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 15 November 2018, 08:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  Module has been rebuilt against 4.14.81
Comment by Edmund Lodewijks (lquidfire) - Wednesday, 14 November 2018, 17:43 GMT
I can confirm that I had the same issue since the update to kernel 4.14.80-1-lts (same error message when booting linux-lts with nvidia-lts). No issues when booting regular (non-lts) kernel.

Video card: 05:00.0 VGA compatible controller: NVIDIA Corporation GK208B [GeForce GT 730] (rev a1)

uname -a: Linux ld-office1 4.14.80-1-lts #1 SMP Sat Nov 10 19:40:49 CET 2018 x86_64 GNU/Linux

Attached is output of:
pacman -Qs nvidia
pacman -Qs linux
dmesg
Xorg.0.log

Loading...