Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60790 - [firefox-developer-edition] Wayland support

Attached to Project: Community Packages
Opened by Julien Lequertier (avrelaun) - Tuesday, 13 November 2018, 13:03 GMT
Last edited by Andrew Crerar (andrewSC) - Wednesday, 04 September 2019, 00:07 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Andrew Crerar (andrewSC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Can we have wayland support compiled in the official firefox-developer-edition package ?

Wayland is now being used y a significant number by the arch community, and will likely increase over time.

The developer edition seems like the right way to introduce it to arch users, either that or a separate package ?

Here's the option en enable wayland at build time: ac_add_options --enable-default-toolkit=cairo-gtk3-wayland

Thanks
This task depends upon

Closed by  Andrew Crerar (andrewSC)
Wednesday, 04 September 2019, 00:07 GMT
Reason for closing:  Fixed
Comment by Yo'av (bjesus) - Saturday, 23 March 2019, 22:22 GMT
Is there any way to help this happen?
Comment by Andrew Crerar (andrewSC) - Wednesday, 27 March 2019, 13:20 GMT
Adding that option, building, then testing with Weston, I still get crashes on startup. bjesus, can you confirm or elaborate more on your setup?
Comment by Yo'av (bjesus) - Wednesday, 27 March 2019, 21:43 GMT
I'm sorry, I couldn't get it to build due to disk space, and couldn't find a binary build, so I tested it on Firefox Beta which I assumed is almost the same. Running it with GDK_BACKEND=wayland ./firefox works just fine, so I assumed it was because it's compiled with Wayland support. But perhaps there are more differences between Beta and Developer Edition than I thought?

The binary Beta version I used is 67.0b5, official build from the Mozilla website.
Comment by Zach (Z750) - Tuesday, 14 May 2019, 19:13 GMT
Tested nightly from Mozilla's website and it runs fine, however the developer-edition also from their site does crash on start up w/ wayland.
I've opened a bug report with them here https://bugzilla.mozilla.org/show_bug.cgi?id=1551664
I assume that perhaps the binary releases of dev edition are not compiled with wayland support? I guess we'll see what they have to say.
Comment by Andrew Crerar (andrewSC) - Wednesday, 15 May 2019, 17:49 GMT
Hey Zach (and Yo'av),

Thanks for taking the initiative to get to the bottom of this. I unfortunately haven't had the time to deep dive into what the problem is specifically due to recent life events (good ones thankfully!). However, my availability will become much higher in about two to three weeks. I'll be keeping an eye on the bug report you filed upstream to see what the outcome is. Hopefully it's simple and resolved quickly. If not I'll gladly try to get to the bottom of it myself in a couple weeks.

Thanks again for the patience everyone!
Comment by Marti (intgr) - Tuesday, 03 September 2019, 16:51 GMT
Hi, it seems Wayland support is now enabled, this issue can be closed?
Comment by Yo'av (bjesus) - Tuesday, 03 September 2019, 20:28 GMT
I can confirm this seems to work now - with Wayland enabled, and with zero crashes.

Loading...