Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60785 - [unzip] Pacman -Suy error: failed to commit transaction (conflicting files)

Attached to Project: Arch Linux
Opened by Sami Haapaniemi (Pisami) - Monday, 12 November 2018, 22:27 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 12 November 2018, 22:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I had unzip installed and ran pacman -Suy and it failed because of conflicting files:

error: failed to commit transaction (conflicting files)
unzip: /usr/bin/funzip exists in filesystem
unzip: /usr/bin/unzip exists in filesystem
unzip: /usr/bin/unzipsfx exists in filesystem
unzip: /usr/bin/zipgrep exists in filesystem
unzip: /usr/bin/zipinfo exists in filesystem
unzip: /usr/share/licenses/unzip/LICENSE exists in filesystem
unzip: /usr/share/man/man1/funzip.1.gz exists in filesystem
unzip: /usr/share/man/man1/unzip.1.gz exists in filesystem
unzip: /usr/share/man/man1/unzipsfx.1.gz exists in filesystem
unzip: /usr/share/man/man1/zipgrep.1.gz exists in filesystem
unzip: /usr/share/man/man1/zipinfo.1.gz exists in filesystem
Errors occurred, no packages were upgraded.

Solution:
$ sudo pacman --remove unzip

There should not be file conflicts, but rather a package conflict.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 12 November 2018, 22:55 GMT
Reason for closing:  Not a bug
Additional comments about closing:  The package itself is not broken, and help with corrupted systems is best dealt with via the support forums.
Comment by Santiago Torres (sangy) - Monday, 12 November 2018, 22:30 GMT
I don't see any other package providing `/usr/bin/funzip` or any of those files. Who owns these files besides unzip in your system?
Comment by Levente Polyak (anthraxx) - Monday, 12 November 2018, 22:31 GMT
how exactly did you get /usr/bin/unzip into your system if not via the unzip package?
Comment by Sami Haapaniemi (Pisami) - Monday, 12 November 2018, 22:48 GMT
The command "pacman -Ql | grep funz" returns nothing. I did not manually install or compile the unzip package, so it must be some kind of bug.
Comment by Eli Schwartz (eschwartz) - Monday, 12 November 2018, 22:54 GMT
I suspect your package database got corrupted somehow (possibly you interrupted pacman during an update).

`pacman -Qkk unzip` will probably report errors. Either that or it will report no files at all owned by the package. Report these errors to the help forums.

Loading...