Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60776 - [netbeans] Import fails

Attached to Project: Community Packages
Opened by Peter Weber (hoschi) - Monday, 12 November 2018, 09:43 GMT
Last edited by Santiago Torres (sangy) - Saturday, 17 November 2018, 23:44 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Santiago Torres (sangy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Hello!
Netbeans 9 is not able to import any projects from Netbeans 8.


Additional info:
* package version(s): 9.0-4
* log:
--------------------------------------------------------------------------------------------
...
INFO [org.netbeans.upgrade.AutoUpgrade]: Importing from /home/peter/.netbeans/8.2 to /home/peter/.netbeans/9.0
WARNING [org.netbeans.upgrade.CopyFiles]: Import settings will not proceed: /usr/lib/netbeans/etc/netbeans.import (No such file or directory)
...
--------------------------------------------------------------------------------------------


Steps to reproduce:
1. # pacman -Syu
2. # archlinux-java set java-11-openjdk
3. $ netbeans


I assumed selecting Java 11 instead of Java 8 is a good thing. But Java 11 breaks the native L&F with Gtk3[1] and introduces issues with NetBeans 8 (other topic...).

Workaround:
Stay with Java 8 and NetBeans 8!

Thanks


[1] https://bugs.openjdk.java.net/browse/JDK-8203627?attachmentOrder=desc
This task depends upon

Closed by  Santiago Torres (sangy)
Saturday, 17 November 2018, 23:44 GMT
Reason for closing:  Fixed
Comment by Peter Weber (hoschi) - Monday, 12 November 2018, 09:43 GMT
Screenshot of NetBeans 9.


PS: If I remember correctly Netbeans 9.0-2 or something like that tried to import something? But failed for other reasons.
Comment by Santiago Torres (sangy) - Thursday, 15 November 2018, 01:16 GMT
Hi, version -5 is up on community-testing. Could you confirm if it fixes your issue?
Comment by Peter Weber (hoschi) - Friday, 16 November 2018, 15:42 GMT
Hello Santiago!
I build netbeans-9.0-5 from community-testing and installed it, it works now.
Thank you!

PS: I will try to add information about nb-javac and the missing plugins (missing JavaEE and Server-Support) to the Wiki.
Comment by Santiago Torres (sangy) - Saturday, 17 November 2018, 23:44 GMT
Glad to hear this fixed your issue, Peter!

I've moved -5 to community/ now, so I'm closing this bug. let me know if you run into any other issues!

Loading...