Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60773 - [mono] /usr/bin/csc conflicts with an existing package

Attached to Project: Arch Linux
Opened by Alexander F. Rødseth (xyproto) - Sunday, 11 November 2018, 19:05 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 11 November 2018, 19:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

mono installs /usr/bin/csc.

However, /usr/bin/csc is already provided by a package older than mono, which is the Scheme compiler Chicken.

Chicken is under active development (http://code.call-cc.org/releases/), and is a well known Scheme compiler, among Scheme developers.

At least one package in AUR depends on both mono and chicken and can no longer be installed because of this conflict: quine-relay (https://aur.archlinux.org/packages/quine-relay/)

I believe /usr/bin/csc should be renamed to something else, because chicken had /usr/bin/csc first.

IMO, we should not cater to developers like the mono developers, that are oblivious to the general open source community, and wish to take over binary names in /usr/bin.

Ideally, we should have register for reserving names in /usr/bin, but this bug report is the next best thing.


Additional info:

mono 5.16.0.179-1
chicken 5.0.0-1

Steps to reproduce:

Try to install both chicken and mono.
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 11 November 2018, 19:09 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#54040

Loading...