Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60763 - [emacs-nox] needs to provide a specific version

Attached to Project: Community Packages
Opened by Yardena Cohen (yardenac) - Saturday, 10 November 2018, 20:20 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 11 November 2018, 00:15 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

emacs-magit from AUR depends on emacs>=25.1 https://aur.archlinux.org/packages/emacs-magit/

This results in a conflict when trying to install alongside emacs-nox, because provides=(emacs) isn't enough to satisfy a versioned dependency. I believe this would be fixed by replacing that with provides=("emacs=${pkgver}")

Thanks!
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 11 November 2018, 00:15 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#52905 

Loading...