Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60717 - [ardour] Can't Launch Ardour

Attached to Project: Community Packages
Opened by Turbo B (Turbo) - Tuesday, 06 November 2018, 16:58 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 13 November 2018, 14:19 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Toady i can lauch Ardour no more. Nothing happens ... When i lauch it from a terminal it gives me the attached output.

It was working well till there.

My system is up-to-date.


Additional info:
* package version(s): Ardour 5.12-7
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 13 November 2018, 14:19 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Theme issue
Comment by Turbo B (Turbo) - Friday, 09 November 2018, 14:32 GMT
The output was in french, here it is in english.
Sorry.
Comment by Turbo B (Turbo) - Friday, 09 November 2018, 14:56 GMT
i found this: http://tracker.ardour.org/view.php?id=5605#c18109

The problem was happening with numix and arc theme from AUR [light & dark version] but Ardour works with xfce default theme. None of the workaround given in the above link works.
Comment by Skottish (skottish) - Sunday, 11 November 2018, 17:53 GMT
The cause of this is the upgrade to gtkmm 2.24.5+6+g85967ecc-2 from gtkmm 2.24.5-2. Downgrading to gtkmm 2.24.5-2 allows Ardour to start again.
Comment by David Runge (dvzrv) - Monday, 12 November 2018, 13:55 GMT
@Turbo: "My system is up-to-date." <- what does that mean? Including testing/community-testing?

To quote Robin Gareus (Ardour): "Interaction with system-wide distribution-specific GTK is not under Ardour's control."
To be more precise: The more you over-modify your system, the more likely you'll break it (that's probably even more so true for GTK ;-) ).
You might want to file the bug against numix-gtk-theme and/or arc-gtk-theme upstream (especially, if there's more gtk stuff not working with it).

@skottish: Did you have testing enabled?
Comment by Turbo B (Turbo) - Monday, 12 November 2018, 16:23 GMT
No testing on my machine.
My system is not over-modify, ardour was the only GTK stuff that was not working but right now it's ok with another theme (adapta).
Comment by Skottish (skottish) - Monday, 12 November 2018, 20:18 GMT
@drzrv: Yes.

Loading...