Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60704 - [wxmaxima] scrolling below the first pages documents are blank

Attached to Project: Arch Linux
Opened by Mariusz Libera (mar04) - Monday, 05 November 2018, 18:34 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 11 November 2018, 21:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

After updating from wxmaxima 18.02 to 18.10 wxm files display correctly only about the first 1 or 2 pages then it's all blank.

Here is a video demonstrating the problem: https://www.youtube.com/watch?v=TKbcpPgIhz8

I opened a bug report upstream at first, but it doesn't seem to affect Ubuntu, so it may be something Arch specific.
Here is upstream report: https://github.com/wxMaxima-developers/wxmaxima/issues/1045

This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 11 November 2018, 21:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  wxmaxima 18.10.2-1
Comment by Gunter Königsmann (gunterkoenigsmann) - Monday, 05 November 2018, 19:06 GMT
I've sent the user here hoping the problem is distribution-specific: on Debian, Mac os andOS and windows everything works. But simetimes, I have to admit, once a bug is found one wonders why.

My guess is that wxDc:;prepare is called in the wrong place in mathctrl::onpaint. But I don't know what the right place would be.
Comment by Gunter Königsmann (gunterkoenigsmann) - Sunday, 11 November 2018, 18:41 GMT
I'll make a new wxMaxima release that fixes this bug this week. But I don't know enough about archlinux to know if it automatically will appear there.
Comment by Gunter Königsmann (gunterkoenigsmann) - Sunday, 11 November 2018, 18:44 GMT

Loading...