Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60668 - ICU upgrade to version 63 breaks binutils "ar" binary and many other programs that require version62

Attached to Project: Arch Linux
Opened by Peter Parker (sp1d3rmxn) - Thursday, 01 November 2018, 13:57 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 01 November 2018, 13:59 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

ICU was upgraded to version 63 however the binutils package that has a binary called "ar" requires ICU version 62. Go ahead and upgrade then try to compile anything that refers to the "libicuuc.so.62" library and it segfaults, this includes "binutils" package since it relies on the ICU package to build, despite the fact that someone left that out as a make depends requirement ICU is actually a requirement.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
Upgrade then simply try to rebuild binutils using "makepkg" as normal. You will get the error:
"ar: libicuuc.so.62: cannot open shared object file: No such file or directory"

For giggles go ahead and try to compile other things, you'll quickly find that the genius who decided to upgrade ICU to version 63 has broken quite a lot more than just binutils.

In the past when these idiotic mistakes have been made I simply did a symlink to the missing library, you can't do that with this as there are symbols it's looking for that will again cause a segfault.

This is so stupid it's almost depressing.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 01 November 2018, 13:59 GMT
Reason for closing:  Not a bug
Additional comments about closing:  please go away forever
Comment by Eli Schwartz (eschwartz) - Thursday, 01 November 2018, 13:59 GMT
ar is not even linked to icu at all, goodbye.

Registering to the bugtracker just to report a false bug, doing so in the rudest possible manner, then claiming "many" packages on a distribution level share this non-bug? This bugreport is so stupid it *is* depressing.

Loading...