Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60637 - SDDM is still using the old libicui18n.so.62 instead of the upgraded libicui18n.so.63

Attached to Project: Arch Linux
Opened by Sakuraba Amane (tobiichiamane) - Tuesday, 30 October 2018, 01:31 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 30 October 2018, 02:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
After upgrading my icu from 62 to 63, sddm won't start anymore.
If the locale is set to en_US.UTF-8 it works perfectly.

Additional info:
* package version(s)
* config and/or log files etc.
sddm version: 0.18.0-1
Log has been uploaded as an attachment.

Steps to reproduce:
Set locale to zh_CN.UTF-8;
Upgrade package icu from 62.1-1 to 63.1-1;
Reboot;
   sddm.log (4.1 KiB)
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 30 October 2018, 02:09 GMT
Reason for closing:  Not a bug
Additional comments about closing:  sddm is not linked to icu at all. Use lddtree from the pax-utils package or set LD_DEBUG=files to figure out where the real problem is.

Loading...