FS#60634 - [firefox] Firefox frozen after suspend

Attached to Project: Arch Linux
Opened by Jamp (jamp) - Monday, 29 October 2018, 19:37 GMT
Last edited by freswa (frederik) - Sunday, 18 October 2020, 01:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No



Firefox 63 frozen upon resuming from suspend.

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:

Under Xfce4 (maybe the desktop environment is unimportant) choose suspend and put the system to sleep while an instance of Firefox 63 is active. Upon system resume the firefox window is totally unresponsive and must be killed
This task depends upon

Closed by  freswa (frederik)
Sunday, 18 October 2020, 01:35 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Reporter identified the issue as an config problem.
Comment by Jamp (jamp) - Tuesday, 30 October 2018, 19:02 GMT
Thing have a bit improved with yesterday firefox version.. 63.0-2 But problems remain.. After a while after resume a strange cursor appeared and the whole screen was blocked.. I had to go to the system console (ctrl alt f2) and kill it..
Comment by Jamp (jamp) - Friday, 02 November 2018, 21:12 GMT
V. 63.0.1 is here and the problem is here too... :-( .. I have another laptop with the same O.S. and there there are no problems with firefox. Could be the problem be related to the NVIDIA driver.. Both have nvidia cards the Thoshiba i5 has an older one and the driver is the 390.87 while I am experiencing problems with an Asus i7 with the 410.66 version.
Comment by Rodrigo Fernandez-Vizarra (rfvizarra) - Friday, 09 November 2018, 16:17 GMT
I'm experiencing the same issue. I also have an NVIDIA card with the proprietary drivers
Comment by Jamp (jamp) - Sunday, 11 November 2018, 11:53 GMT
Glad that others have my same problem.. I add another cool effect of firefox on arch 4.18.16-arch1-1-ARCH nvidia-410.66 ... please try to go to this page
https://www.ktm.com/en/travel/790-adventure-r/ and scroll down.. what happens to me is the X server crash.
Comment by Jamp (jamp) - Tuesday, 13 November 2018, 20:09 GMT
just to inform you that, after the upgrade to the latest kernel (4.19.1) and nvidia driver (410.73) , the problems remain the same. Maybe it is worth to report the X server crash in a separate task ? Thanks
Comment by f (bakgwailo) - Saturday, 17 November 2018, 08:36 GMT
I also have this problem on my laptop. NVIDIA card (latest 410 drivers from main repos), KDE/Plasma. On resume Firefox ends up just freezing up pretty quickly (maybe a few minutes at best) required a kill statement to restart.

My desktop (also KDE/Plasma and NVIDIA, basically exact same software stack, no testing repos, etc) does not seem to have the problem, though.
Comment by Thomas Hebb (tchebb) - Monday, 19 November 2018, 03:54 GMT
Also happening for me with NVIDIA proprietary drivers 410.73-3 and Firefox 63.0.3-1.
Comment by f (bakgwailo) - Monday, 19 November 2018, 04:51 GMT
attaching what I believe is the segfault in dmesg from when firefox dies (and pegs 100% of a cpu core).
Comment by stargazer (bernie) - Monday, 19 November 2018, 15:32 GMT
Same with KDE 5.14.3 and nvidia driver 390.87, kernel 4.14.81-1-lts
Comment by Sebastian Lövdahl (slovdahl) - Wednesday, 21 November 2018, 19:21 GMT
Probably this one: https://bugzilla.mozilla.org/show_bug.cgi?id=1484782
Infinite loop in GLContext::RawGetErrorAndClear from endless GL_CONTEXT_LOST with Nvidia Linux drivers and suspend/resume
Comment by f (bakgwailo) - Wednesday, 26 December 2018, 18:48 GMT
That looks like it was closed with Firefox 63 as the milestone - this is still happening for me on Firefox 63 (and 64).
Comment by f (bakgwailo) - Monday, 25 February 2019, 23:02 GMT
Also would like to add - turning forced hardware accel off in about:config fixed this.
Comment by f (bakgwailo) - Tuesday, 26 February 2019, 17:27 GMT
Also would like to add - turning forced hardware accel off in about:config fixed this.
Comment by Pedro B (pikimeister) - Monday, 04 March 2019, 07:36 GMT
Issue still persists as of today.

Firefox: 65.0.2-1
Nvidia Drivers: 418.43-4
Kernel: 4.20.13
Comment by ArchLoy (Loy) - Thursday, 22 August 2019, 17:28 GMT
I have also the same problem. My laptop have Nvidia driver. Tried :
seems working. Maybe fixed in future release... Maybe.

EDIT : It doesn't works for me.

Thanks for help !
Comment by Jamp (jamp) - Friday, 20 September 2019, 15:50 GMT

I "solved" the problem by creating a new mozilla profile. I.E. I renamed the old one in the .mozilla/firefox folder so that Firefox created a new one upon restart. The problem gone away toghether with the "evil" inside the old profile.