Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60620 - [rhythmbox] fails to build

Attached to Project: Arch Linux
Opened by Erich Eckner (deepthought) - Sunday, 28 October 2018, 11:00 GMT
Last edited by Jan de Groot (JGC) - Sunday, 03 February 2019, 22:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

extra-x86_64-build fails with:

error: Package `gstreamer-0.10' not found in specified Vala API directories or GObject-Introspection GIR directories
error: Package `gstreamer-0.10' not found in specified Vala API directories or GObject-Introspection GIR directories

Additional info:
* package version(s)
rhythmbox 3.4.2+4+ge123ad533-2 (git revision 1e9518653e904f3019b6e42d8d2265ab6aa1df0e)
* config and/or log files etc.
full log is attached

Steps to reproduce:
> git checkout 1e9518653e904f3019b6e42d8d2265ab6aa1df0e
> cd rhythmbox/repos/extra-x86_64
> extra-x86_64-build
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 03 February 2019, 22:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.4.3-1
Comment by loqs (loqs) - Sunday, 28 October 2018, 13:41 GMT
Upstream issue both in the commit arch is currently using
https://gitlab.gnome.org/GNOME/rhythmbox/blob/e123ad533503b231f68612fcb92884c0f391c5b0/sample-plugins/sample-vala/Makefile.am#L36
and in the current master
https://gitlab.gnome.org/GNOME/rhythmbox/blob/22dc93119ab9a2c695143164ab28c0aec6b4d2bf/sample-plugins/sample-vala/Makefile.am#L36
Please report upstream.
As a workaround in the PKGBUILD sample-plugins could be removed the subdirs entry in the top Makefile.am and the rm for sample-plugins in the package function removed.

Updating to 22dc93119ab9a2c695143164ab28c0aec6b4d2bf build fails because of https://gitlab.gnome.org/GNOME/rhythmbox/issues/1599
patch in the bug report plus previous mentioned changes allows package to be built successfully.

Loading...