Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60593 - [gnuradio] optional dependency python2-cheetah is not exactly optional

Attached to Project: Community Packages
Opened by Martin Rys (C0rn3j) - Friday, 26 October 2018, 08:19 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 26 October 2018, 12:02 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I installed packages gnuradio (3.7.13.4-4) and gnuradio-osmosdr (0.1.4-28) and launching gnuradio-companion then failed on missing python2-cheetah dependency.

Additional info:
c0rn3j@Luxuria : ~
[0] % gnuradio-companion
Traceback (most recent call last):
File "/usr/bin//gnuradio-companion", line 99, in <module>
run_main()
File "/usr/bin//gnuradio-companion", line 87, in run_main
from gnuradio.grc.main import main
File "/usr/lib/python2.7/site-packages/gnuradio/grc/main.py", line 23, in <module>
from .gui.Platform import Platform
File "/usr/lib/python2.7/site-packages/gnuradio/grc/gui/Platform.py", line 23, in <module>
from ..core.Platform import Platform as _Platform
File "/usr/lib/python2.7/site-packages/gnuradio/grc/core/Platform.py", line 27, in <module>
from .generator import Generator
File "/usr/lib/python2.7/site-packages/gnuradio/grc/core/generator/__init__.py", line 18, in <module>
from Generator import Generator
File "/usr/lib/python2.7/site-packages/gnuradio/grc/core/generator/Generator.py", line 23, in <module>
from Cheetah.Template import Template
ImportError: No module named Cheetah.Template

c0rn3j@Luxuria : ~
[1] % trizen -S python2-cheetah --noconfirm
python2-markdown-2.6.11-2-any 103.4 KiB 3.06M/s 00:00 [------------------------------------------------------] 28%
python2-cheetah-2.4.4-7-x86_64 356.8 KiB 2.05M/s 00:00 [------------------------------------------------------] 100%

c0rn3j@Luxuria : ~
[0] % gnuradio-companion
<<< Welcome to GNU Radio Companion 3.7.13.4 >>>
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 26 October 2018, 12:02 GMT
Reason for closing:  Not a bug
Additional comments about closing:  gnuradio-companion is an optional part of the package

Loading...