Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60575 - [tribler] Missing dependency on python2-pyopenssl and redundant optional dependency on vlc

Attached to Project: Community Packages
Opened by grizzlyuser (grizzly) - Wednesday, 24 October 2018, 11:11 GMT
Last edited by Filipe Laíns (FFY00) - Saturday, 10 November 2018, 15:53 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Filipe Laíns (FFY00)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

Steps to reproduce:
1. sudo pacman -S tribler
2. run tribler either from the GUI or from the terminal.

Expected results:
It runs and all features work.

Actual results:
A window opens with animated gears that spin endlessly. There's a file named f-tribler-[random_characters].log in the /tmp/, which ends with the following message:
ImportError: No module named OpenSSL

Additional info:
* package version(s): 7.1.0-1
* works fine if python2-pyopenssl is installed

Also, tribler package has optional dependency on vlc, but already depends on phonon-qt5-vlc, which depends on vlc. So there's either no need for this optional dependency for tribler, or probably it should depend on phonon-qt5-backend instead?


Steps to reproduce:
This task depends upon

Closed by  Filipe Laíns (FFY00)
Saturday, 10 November 2018, 15:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  tribler 7.2.0_exp1-2
Comment by grizzlyuser (grizzly) - Thursday, 25 October 2018, 13:38 GMT
Today I installed Arch in a virtual machine, with gnome group only, and tried to install tribler 7.1.1-1 afterwards. Found the following missing dependencies:

python2-pyopenssl
python2-meliae
python2-pillow
python2-service-identity
python2-faulthandler

Tribler doesn't start without the first three. Without the last two it starts, but complains in the log that those modules are not found.
Comment by Rich Deeson (lightstream) - Thursday, 25 October 2018, 18:05 GMT
I confirm this bug. Installed tribler yesterday (not in a VM), and it would not start without the first three.
Comment by Vasili (3point2) - Friday, 09 November 2018, 21:06 GMT
After installing the above dependencies, I still get
<code>
INFO 1541796783.89 single_application:23 (root) __init__()
INFO 1541796783.99 single_application:49 (root) self._outSocket.error() = '2'
INFO 1541796783.99 single_application:60 (root) __init__(): returning
INFO 1541796785.23 event_request_manager:148 (TriblerGUI) Will connect to events endpoint
INFO 1541796785.37 event_request_manager:52 (TriblerGUI) Got Tribler core error: 1
Traceback (most recent call last):
File "run_tribler.py", line 86, in <module>
start_tribler_core(base_path, api_port)
File "run_tribler.py", line 45, in start_tribler_core
from Tribler.Core.Session import Session
File "/usr/share/tribler/Tribler/Core/Session.py", line 20, in <module>
from Tribler.Core.APIImplementation.LaunchManyCore import TriblerLaunchMany
File "/usr/share/tribler/Tribler/Core/APIImplementation/LaunchManyCore.py", line 16, in <module>
from pony.orm import db_session
ImportError: No module named pony.orm
INFO 1541796805.97 run_tribler:128 (root) Shutting down Tribler
</code>

Loading...