Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60571 - [dotnet-sdk] Needs DOTNET_ROOT=/opt/dotnet to work

Attached to Project: Community Packages
Opened by alpha numeric (alphanumeric) - Tuesday, 23 October 2018, 21:53 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 04 November 2018, 00:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
For some commands like `dotnet dev-certs` it is needed to have the environment variable `DOTNET_ROOT` set to `/opt/dotnet`. Otherwise it complains of a missing file `libhostfxr.so` (which actually exists in /opt/dotnet/host/fxr/2.1.5/libhostfxr.so).

It would be nice if the package had a file `/etc/profile.d/dotnet.sh` with the content `export DOTNET_ROOT=/opt/dotnet` so it gets added automatically.


Additional info:
* package version(s): 2.1.5+403-1


Steps to reproduce:
* Install dev-certs with `dotnet tool install --global dotnet-dev-certs`
* dotnet instructs to add `~/.dotnet/tools` to our $PATH (this still has to be done by the user manually but at least we get a notification beforehand)
* run `dotnet dev-certs --help`
* dotnet gives an error regarding missing `libhostfxr.so`
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 04 November 2018, 00:52 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#59263 
Comment by alpha numeric (alphanumeric) - Tuesday, 23 October 2018, 22:01 GMT
Pardon the alarming title, only noticed after posting the issue and couldn't find a way to edit it. The environment variable is not required for dotnet itself to work, but it seems required for running extra dotnet tools.
Comment by Mateusz Paluszkiewicz (TheAifam5) - Sunday, 28 October 2018, 18:27 GMT
I have the same issue while using user-secrets tool. Please fix it.
Comment by Mateusz Paluszkiewicz (TheAifam5) - Sunday, 28 October 2018, 18:28 GMT
The same issue:  FS#59263 
Comment by Adilson Schmitt Junior (sirgallifrey) - Monday, 29 October 2018, 13:20 GMT
I had the same problem, even opened and issue at the dotnet docs repo: https://github.com/aspnet/Docs/issues/9195

Is a symlink from /usr/share/dotnet pointing to /opt/dotnet a good idea? It would at least not be a breaking change.
Comment by Adilson Schmitt Junior (sirgallifrey) - Monday, 29 October 2018, 17:51 GMT
I had the same problem, even opened and issue at the dotnet docs repo: https://github.com/aspnet/Docs/issues/9195

Is a symlink from /usr/share/dotnet pointing to /opt/dotnet a good idea? It would at least not be a breaking change.

Loading...