Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60534 - [linux] Build in VFIO made passthrough very difficult

Attached to Project: Arch Linux
Opened by Tom Yan (tom.ty89) - Monday, 22 October 2018, 17:30 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 22 October 2018, 17:33 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=fe9bab556d810ba4bb968f60e834fa7b31a3e5e0

Before this commit we can have the vfio-pci module (and its deps) and a modprobe.d conf with IDs of the wanted devices in an initcpio image, which guarantees that it takes over them before any other drivers (because the manually added module are always loaded first).

With this commit that cannot be accomplished anymore. Not in every case the other drivers can simply be blacklisted to achieve the equivalence result as they are often shared by devices we do not want to passthrough, like an extra sound card, extra XHCI controller, or maybe even GPU if they are from the same vendor (AMD?). We could at best do the rebind manually through sysfs, which does not necessarily work for all kinds of devices.


Additional info:
* package version(s) 4.18.16.arch1-1
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 22 October 2018, 17:33 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#46505 

Not exactly a duplicate, but better to keep all of the conversation in the same place.

Loading...