Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60510 - [matrix-synapse] python2-treq is a dependency

Attached to Project: Community Packages
Opened by Damjan Georgievski (damjan) - Saturday, 20 October 2018, 18:21 GMT
Last edited by Johannes Löthberg (demize) - Sunday, 21 October 2018, 18:53 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Johannes Löthberg (demize)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

seems that python2-treq was only added as a check dependency, but it is required at runtime:

Oct 20 17:41:39 arch systemd[1]: Started Synapse Matrix homeserver.
Oct 20 17:41:42 arch python2.7[30182]: ERROR:root:Can't import 'treq' which is part of 'treq>=15.1'
Oct 20 17:41:42 arch python2.7[30182]: Traceback (most recent call last):
Oct 20 17:41:42 arch python2.7[30182]: File "/usr/lib/python2.7/site-packages/synapse/python_dependencies.py", line 131, in check_>
Oct 20 17:41:42 arch python2.7[30182]: module = __import__(module_name)
Oct 20 17:41:42 arch python2.7[30182]: ImportError: No module named treq
Oct 20 17:41:42 arch python2.7[30182]: Missing Requirement: Can't import 'treq' which is part of 'treq>=15.1'
Oct 20 17:41:42 arch python2.7[30182]: To install run:
Oct 20 17:41:42 arch python2.7[30182]: pip install --upgrade --force "treq>=15.1"
This task depends upon

Closed by  Johannes Löthberg (demize)
Sunday, 21 October 2018, 18:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.33.7-2
Comment by Jean Lucas (flacks) - Sunday, 21 October 2018, 17:48 GMT
python2-psutil is also another required run-time dependency. Synapse will not start without it.

Loading...