Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60482 - [gnustep-make] clash with gnustep-base

Attached to Project: Community Packages
Opened by Ernest Grothauzen (Lone_Wolf) - Thursday, 18 October 2018, 19:13 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 04 November 2018, 16:07 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Anatol Pomozov (anatolik)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

gnustep-make 2.7.0-3 and gnustep-base 1.25.1-3 are build with conflicting settings wrt exceptions.

gnustep-make has --enable-native-objc-exceptions which explicitly enables compiler native exceptions.
Otoh gnustep-base doesn't set an exception type which defaults to traditional exceptions.

see https://aur.archlinux.org/packages/gnustep-gui/ for the exact error message.
(Comment by SpaceboyRoss on 2018-10-18)

This task depends upon

Loading...