Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60482 - [gnustep-make] clash with gnustep-base

Attached to Project: Community Packages
Opened by Lone_Wolf (Lone_Wolf) - Thursday, 18 October 2018, 19:13 GMT
Last edited by Anatol Pomozov (anatolik) - Thursday, 30 July 2020, 10:30 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Anatol Pomozov (anatolik)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

gnustep-make 2.7.0-3 and gnustep-base 1.25.1-3 are build with conflicting settings wrt exceptions.

gnustep-make has --enable-native-objc-exceptions which explicitly enables compiler native exceptions.
Otoh gnustep-base doesn't set an exception type which defaults to traditional exceptions.

see https://aur.archlinux.org/packages/gnustep-gui/ for the exact error message.
(Comment by SpaceboyRoss on 2018-10-18)

This task depends upon

Closed by  Anatol Pomozov (anatolik)
Thursday, 30 July 2020, 10:30 GMT
Reason for closing:  Not a bug
Comment by Beebo (Beebo) - Saturday, 11 July 2020, 15:55 GMT
Anything that depends on gnustep-make can no longer compile.
I've received a couple of reports about it in the AUR too.
Comment by Anatol Pomozov (anatolik) - Thursday, 23 July 2020, 19:37 GMT
I am not good at the gnustep toolchain so it is not clear for me what would be the best solution for it. Do you have an advice how to fix it? Ideally if you can provide a PKGBUILD patch for it.
Comment by Beebo (Beebo) - Saturday, 25 July 2020, 05:25 GMT
The culprit were the AUR packages `gnustep-gui` and `gnustep-back` packages being out-of-date. I've upgraded them from 0.27 to 0.28 and published the changes.
Ideally, shouldn't these 2 packages be moved to the community repository alongside gnustep-base and gnustep-make?

@anatolik you can make this as resolved.

Loading...