Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#6042 - syncing deps with upgrade option ( -U ) or give url to -S

Attached to Project: Pacman
Opened by Jeff Mickey (codemac) - Tuesday, 19 December 2006, 23:16 GMT
Task Type Feature Request
Category
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

While testing out all these new packages recently, a lot of the time I just download the *.pkg.tar.gz, and then pacman3 -U *.pkg.tar.gz. The problem is that it will then complain about uninstalled deps. I would like to have the dependencies synced in with the correct notations in the pacman database, but there is no current way to accomplish this with pacman3.

I have 2 possible solutions.

1) Add a -Us option to sync deps from the current pacman db. Maybe even add a -Ul to search the current directory for *.pkg.tar.gz of the correct dependency before checking the pacman db.

2) Let -S take a url, thus downloading the package temporarily and then syncing the install with the pacman db.

I prefer #1, but there are many ways to go about this.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Friday, 16 February 2007, 19:42 GMT
Reason for closing:  Duplicate
Additional comments about closing:  http://bugs.archlinux.org/task/5798

Loading...