Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60386 - [wpa_supplicant] Compile against latest version of OpenSSL

Attached to Project: Arch Linux
Opened by Karol Babioch (kbabioch) - Thursday, 11 October 2018, 19:32 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 11 October 2018, 19:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Due to a bug in the past [1], wpa_supplicant is build against OpenSSL 1.0. This has been fixed by upstream in the meantime [2]. There have been also a series of other commits in regards to OpenSSL 1.1.0, so we should build wpa_supplicant against the latest version of OpenSSL to minimize the number of packages still requiring the old version. There have been similar bugs [3] to make the switch in the past, which were closed, but I think it might be time to re-visit this. Also Fedora has switched a while ago, and it seems to work fine for them.

[1]: https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/wpa_supplicant&id=c0a268e0f110ca5e67b7ffe1fbcee2d0d84d49e6
[2]: https://w1.fi/cgit/hostap/commit/?id=f665c93e1d28fbab3d9127a8c3985cc32940824f
[3]: https://bugs.archlinux.org/task/54390

Additional info:
* package version(s): 1:2.6-12
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 11 October 2018, 19:51 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#54390 

Loading...