Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60376 - [unbound] daemon does not start with supplied systemd unit

Attached to Project: Community Packages
Opened by PyroPeter (pyropeter) - Wednesday, 10 October 2018, 18:48 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 10 October 2018, 20:01 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The Unbound package does not include the systemd units supplied upstream, but a custom one (which looks really bad compared to the upstream one). This unit is not able to start up the daemon if it isn't configured with 'do-daemonize:no' in its configuration file. (The daemon is started, but obviously systemd kills the child after the parent exits.)

It would probably be best if the package would just use the upstream units?

Additional info:
* unbound 1.8.0-1
* systemd 239.2-1


Steps to reproduce:
* systemd start unbound
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 10 October 2018, 20:01 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Config issue. Make sure to merge your pacnew files

Loading...