Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60358 - Since latest Linux desktop 4.18.* changes, no more USB init on boot

Attached to Project: Arch Linux
Opened by Francois (francoism90) - Tuesday, 09 October 2018, 12:43 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 09 October 2018, 14:50 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When using something like `cryptkey=/dev/disk/by-uuid/..:ext4:/keys/mykey` as kernel parameter, it no longer reads the USB-stick. This wasn't an issue on Linux 4.17. Maybe this is caused by the USB-keyboard changes?

Additional info:
* Linux 4.18.12.arch1-1
* Kernel parameter: cryptkey=/dev/disk/by-uuid/..:ext4:/keys/mykey with systemd-boot


Steps to reproduce:
* Downgrade kernel to 4.17, reads cryptkey
* Upgrading kernel to 4.18, doesn't read USB at all.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 09 October 2018, 14:50 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#60272 

Loading...