Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60349 - [ffmpeg] 1:4.0.2-4 cannot be installed ; dependency libx265 cannot be satisfied

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Monday, 08 October 2018, 12:38 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 08 October 2018, 13:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description: tried to upgrade my system and I got this error:

resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libx265.so=160-64' required by ffmpeg
Error installing repo packages

Additional info:

ffmpeg 1:4.0.2-4

Steps to reproduce:

Just try to upgrade your system.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 08 October 2018, 13:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  ffmpeg 1:4.0.2-6
Comment by nl6720 (nl6720) - Monday, 08 October 2018, 12:44 GMT
Same issue for me.

`pacman -Syu --debug`:
..
debug: new version of 'ffmpeg' found (1:4.0.2-3 => 1:4.0.2-4)
debug: adding package ffmpeg-1:4.0.2-4 to the transaction targets
...
debug: new version of 'x265' found (2.8-1 => 2.9-1)
debug: adding package x265-2.9-1 to the transaction targets
...
resolving dependencies...
...
debug: checkdeps: package ffmpeg-1:4.0.2-4
debug: checkdeps: missing dependency 'libx265.so=160-64' for package 'ffmpeg'
debug: provider found (x265 provides libx265.so)
debug: finished resolving dependencies
...
debug: checking dependencies
debug: checkdeps: package ffmpeg-1:4.0.2-4
debug: checkdeps: missing dependency 'libx265.so=160-64' for package 'ffmpeg'
...
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libx265.so=160-64' required by ffmpeg
Comment by Frederic Bezies (fredbezies) - Monday, 08 October 2018, 12:50 GMT
Seems to be fixed by 1:4.0.2-6 version.
Comment by Tagne (Tagne) - Monday, 08 October 2018, 12:51 GMT
Same issue for me.

It seems that the dependency version was not updated in the new build of ffmpeg.
EDIT : fixed in 1:4.0.2-6
Comment by John Piers (johnpiers) - Monday, 08 October 2018, 12:58 GMT
"unable to satisfy dependency 'libx265.so=160-64' required by ffmpeg"

Just replying here so I get a notification when this is resolved or whatever.

Thanks for the speedy correction and apologies for the "me too" post.
Comment by Maximilian Konter (Biskit1943) - Monday, 08 October 2018, 13:26 GMT
I too have this Problem here, after uninstalling all packages which depend on ffmpeg and trying to reinstall ffmpeg it fails:

resolving dependencies...
warning: cannot resolve "libx265.so=160-64", a dependency of "ffmpeg"
:: The following package cannot be upgraded due to unresolvable dependencies:
ffmpeg

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libx265.so=160-64' required by ffmpeg
Comment by Eli Schwartz (eschwartz) - Monday, 08 October 2018, 13:52 GMT
Please don't post "me too" replies just to get notifications, as that results in everyone else who did the same thing getting the same pointless notifications, and also results in people who want to figure out the status having to sift through no-content comments in order to figure out what is going on.

Every bug already has a link:
Watching No (watch task)

Which you can click to, well, watch the task. Without bothering other people in the process.

Please save your comments for the case where you actually have something useful to contribute to the discussion.

Loading...