Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60339 - [cyrus-sasl] Need to recompile the package for gdbm

Attached to Project: Arch Linux
Opened by Shane Chen (ss1h2a3tw) - Sunday, 07 October 2018, 17:18 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 07 October 2018, 17:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The cyrus-sasl 2.1.26-12 package's sasldb is not working properly.
Need to recompile due to the update of gdbm 1.18-1.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 07 October 2018, 17:50 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#59873 
Comment by Doug Newgard (Scimmia) - Sunday, 07 October 2018, 17:20 GMT
Specific problems?
Comment by Shane Chen (ss1h2a3tw) - Sunday, 07 October 2018, 17:25 GMT
having logs like these
postfix/submission/smtpd[17626]: warning: SASL authentication failure: Couldn't fetch entry from /etc/sasldb2: gdbm_errno=0
while postfix failed to authenticate with sasldb configured.
I have checked that gdbm_errno=0 means there are no errors, so I downgraded gdbm and everything works fine, it seems to be a linking issue.

Loading...