Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60333 - namcap exits 0 when errors found

Attached to Project: Arch Linux
Opened by Tom Hale (Ataraxy) - Sunday, 07 October 2018, 10:04 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 07 October 2018, 14:22 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

namcap 3.2.7 exits 0 on error

I expect that if any errors are found, it exits 1.

I expect that if any warnings are given, it also exits 1.


Steps to reproduce:

namcap /dev/null
echo $?
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 07 October 2018, 14:22 GMT
Reason for closing:  Not a bug
Additional comments about closing:  namcap runs fine, so exiting with an error makes no sense

Loading...