Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60325 - [cppo] Package needs to be recompiled against OCaml 4.07

Attached to Project: Community Packages
Opened by Jakob Gahde (J5lx) - Saturday, 06 October 2018, 14:04 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Monday, 22 October 2018, 09:15 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bruno Pagani (ArchangeGabriel)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
The current binary package of cppo in community (1.6.4-1) was compiled before the release of OCaml 4.07, therefore any attempts to build other OCaml software against that package and the current version of ocaml in extra (as of now 4.07.0-1, but flagged out of date) will fail with an error message such as the following:

Error: /usr/lib/ocaml/cppo_ocamlbuild/ocamlbuild_cppo.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.

To fix this issue, the cppo package must be recompiled against OCaml 4.07. However, it appears that due to changes in the dune build system, the installation procedure in the PKGBUILD needs to be updated as well.

Steps to reproduce:
- Obtain ocaml-ppx_deriving from the AUR and attempt to build it. The build will fail with the error message given above.
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Monday, 22 October 2018, 09:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  No answer, closing.
Comment by Bruno Pagani (ArchangeGabriel) - Thursday, 11 October 2018, 18:42 GMT
Please check the new version.

Loading...