Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60322 - linux 4.18.12.arch1-1 cannot boot from external USB disk

Attached to Project: Arch Linux
Opened by Maxim (mxfm) - Saturday, 06 October 2018, 07:51 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 06 October 2018, 08:07 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Kernel version linux 4.18.12.arch1-1 breaks boot because it lacks 'usb_storage' module which is necessary to boot if arch is installed on external USB drive.

According to 'lsblk' and 'blkid' output from initramdisk there is no external usb drive, but the disk is visible in dmesg output (only as VendorId, ProductId, no dev node is created). According to output from 'lsmod' (from initramdisk) there is no 'usb_storage' module loaded and it is not available in '/lib/modules/.../kernel' path.


Additional info:
* package version(s): linux 4.18.12.arch1-1
* config and/or log files etc: n/a


Steps to reproduce:
1) Install arch on external usb drive.
2) Boot kernel 4.18.12.arch1-1

Workaround: boot from arch iso -> place 'usb_storage' in "Modules=" line in '/etc/mkinitcpio.conf' -> run 'mkinitcpio -p linux' -> reboot
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 06 October 2018, 08:07 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#60272 

Loading...