Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#6031 - 0.8 installation ISO showstoppers

Attached to Project: Arch Linux
Opened by Tobias Powalowski (tpowa) - Monday, 18 December 2006, 20:20 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 31 March 2007, 06:42 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Critical
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Bug collector for 0.8 final ISO:
- docs are still from 0.7.2 install iso
- keymap HOOK bug, fixed
- timezone bug, fixed
- switching to grub usage instead of isolinux, done
- usb,firewire and net boot support is missing in fallback image and should be added optionally to default image, fixed
- lilo always installs on /dev/hda, user should be asked about that like with grub, fixed
- lvm2 fallback, fixed
- quickinst has to be reviewed, done
- fstab could get duplicate entries, fixed
- mountpoints could be mounted twice, fixed
- grub fails to install on xfs, fixed
- hwdetect needs to be fixed for PATA/IDE stuff in qemu and other cases, fixed
- kernel26 only show message for piix for upgraders < 2.6.19, fixed
Closed by  Tobias Powalowski (tpowa)
Saturday, 31 March 2007, 06:43 GMT
Reason for closing:  Fixed
Comment by Thomas Bächler (brain0) - Monday, 18 December 2006, 21:55 GMT
timezone also fixed in CVS, grub should be implemented within an hour or so.
Comment by Thomas Bächler (brain0) - Tuesday, 19 December 2006, 00:14 GMT
grub has been implemented. only docs are missing then.

If any user has more comments, ...
Comment by Glenn Matthys (RedShift) - Tuesday, 19 December 2006, 19:44 GMT
It would be nice if this were fixed too for the 0.8 install cd:

initrd provides no support for bootable partitionable arrays
bhttp://bugs.archlinux.org/task/6027
Comment by Thomas Bächler (brain0) - Tuesday, 19 December 2006, 20:12 GMT
I have no idea how this works and what is necessary to implement it. Please help us :)
Comment by Moo-Crumpus (Moo-Crumpus) - Saturday, 23 December 2006, 13:29 GMT
It boots until

Code:

booting Arch Linux Install ...
..
/initrd /boot/initrd.img
[Linux-initrd .... bytes]

and freezes then.

I run sata and scsi devices (aic7xxx, sata_sil, sata_promise).

Neither noapic, nore acpi=off, pci=routing or nosmp helps me.
Comment by Florian (fk) - Saturday, 23 December 2006, 19:20 GMT
A little cosmetic error:

After kernel install, the warning message

ATTENTION\n <-- should be without \n
Comment by Tobias Powalowski (tpowa) - Sunday, 24 December 2006, 08:36 GMT
the kernel message is not a bug its needed for booting not for upgrading
Comment by Florian (fk) - Sunday, 24 December 2006, 09:27 GMT
Do you mean my comment?

PS: Das \n soll weg nicht die ganze Warnung, das \ is doch nur für den Zeilenumbruch da, da ist aber wohl was schiefgelaufen
Comment by Ruben Fonseca (krani1) - Tuesday, 26 December 2006, 12:40 GMT
the mirror list is not updated
Comment by Roman Kyrylych (Romashka) - Tuesday, 26 December 2006, 12:50 GMT
The mirror list is distributed with pacman.
Maybe installer can just copy updatef files to /etc/pacman.d/ ?
Also note that for extra and unstable repos nethat mirror is higher than archlinux, which leads to update errors when they are out of sync.
It is important that mirror lists will have the same order for all repos.
Comment by Ruben Fonseca (krani1) - Tuesday, 26 December 2006, 12:58 GMT
ok sorry, problem reported to pacman bugtrack :)
Comment by Andreas Radke (AndyRTR) - Wednesday, 27 December 2006, 07:33 GMT
a lilo related bug - http://bugs.archlinux.org/task/5808 - should be solve for i686 (if affected) before release
Comment by Tobias Powalowski (tpowa) - Saturday, 30 December 2006, 13:34 GMT
pacman mirror list is done, lilo is also done
Comment by Roman Kyrylych (Romashka) - Saturday, 30 December 2006, 13:38 GMT
tpowa, the mirror list is not the latest. Take a look at pacman3 CVS.
Comment by Christ Schlacta (aarcane) - Tuesday, 09 January 2007, 15:58 GMT
neither of these bugs apply directly to this:
 FS#6170  - XFS ACL Broken
 FS#6171  - problem with XFS realtime volumes.

new bug: Problem with LVM volumes in install scripts:

under certain circumstances, lvm volumes are listed twice in device selection pages.
Comment by Roman Kyrylych (Romashka) - Tuesday, 09 January 2007, 17:15 GMT
Christ, please file a separate bugreport for this bug and I'll add its number here
Comment by Tobias Powalowski (tpowa) - Monday, 15 January 2007, 21:00 GMT
ok everyhing marked as solved should be fixed in
ftp://ftp.archlinux.org/other/0.8/i686
base-0.8-20070115-i686.iso current-0.8-20070115-i686.iso ftp-0.8-20070115-i686.is
Comment by Florian (fk) - Tuesday, 16 January 2007, 18:34 GMT
I have forgot to plug in my Network cabel at booting from the newest FTP ISO, and the installer don't recognice that there is a NIC, I had try to load the module manually, this works, but the installer says there is no NIC, I have to reboot to get my NIC recogniced.

Not a big Problem , but a smal one
Comment by Roman Kyrylych (Romashka) - Thursday, 08 March 2007, 14:18 GMT
Added #6554. Though it is FR but we have FRs here anyway. :-P It is trivial to implement.
Comment by Sven Kauber (sven) - Wednesday, 28 March 2007, 09:14 GMT
I tried 0.8 beta 2 ISO yesterday and can add that I could not make the LVM2 root to be recognized by the installer and grub. I was not able to root () and setup (). When I made a 700MB root partition and made all the others was LVM2 volumes, then installation went smoothly.
Comment by Roman Kyrylych (Romashka) - Wednesday, 28 March 2007, 09:23 GMT
Sven, please try one of these ISOs http://www.archlinux.org/~tpowa/final/
Comment by Sven Kauber (sven) - Friday, 30 March 2007, 19:36 GMT
Ok, great if you got this problem with lvm2 solved. I already did more configuration steps (installed Xorg, Beryl and some programs), but next time I'll reinstall, I'll try to set up the lvm2 root again.
Comment by Tobias Powalowski (tpowa) - Saturday, 31 March 2007, 06:43 GMT
new collector bug for upcoming version is here:
http://bugs.archlinux.org/task/6767

Loading...