Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60297 - [llvm6] Installing this package causes a conflict with the lib32-llvm package.

Attached to Project: Arch Linux
Opened by Kerr (zefkerrigan) - Wednesday, 03 October 2018, 21:29 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 03 October 2018, 21:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Installing the llvm6 package causes a conflict with the lib32-llvm package because the llvm6's PKGBUILD is missing a line:

provides=('llvm')

Additional info:
* package version: 6.0.1-2

I already fixed this PKGBUILD and attached it here:
   PKGBUILD (3.8 KiB)
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 03 October 2018, 21:38 GMT
Reason for closing:  Not a bug
Additional comments about closing:  llvm6 does not provide llvm on account of it doesn't work for lib32-llvm *7*

Loading...