Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60269 - [borg] msgpack

Attached to Project: Community Packages
Opened by Mantas Mikulėnas (grawity) - Monday, 01 October 2018, 17:43 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 03 October 2018, 03:27 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 17
Private No

Details

Yep, it's that time of year again.

```
$ borg
Traceback (most recent call last):
File "/usr/bin/borg", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3112, in <module>
@_call_aside
File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3096, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3125, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 578, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 895, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 781, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'msgpack-python!=0.5.0,!=0.5.1,!=0.5.2,!=0.5.3,!=0.5.4,!=0.5.5,<=0.5.6,>=0.4.6' distribution was not found and is required by borgbackup
```

local/borg 1.1.7-1
local/python-msgpack 0.5.6-2
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 03 October 2018, 03:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  borg 1.1.7-2
Comment by Jensen McKenzie (your_doomsday) - Monday, 01 October 2018, 19:11 GMT
Broken package should higher severity than "Low".
Comment by Gerhard Bogner (slashME) - Monday, 01 October 2018, 21:52 GMT
Same problem here.
Comment by Mark (sdkyuzo) - Tuesday, 02 October 2018, 04:27 GMT
Unfortunately I opened a bug report before finding the 'search for bugs' feature and sadly I did not notice the 'PLEASE ENTER SUMMARY' title, so I'm requesting my bug report be closed, but here is the information I had shared in that bug report which includes a manual fix for those that might currently be dead in the water until this is resolved:

---

Description:
borg fails with the message:
pkg_resources.DistributionNotFound: The 'msgpack-python!=0.5.0,!=0.5.1,!=0.5.2,!=0.5.3,!=0.5.4,!=0.5.5,<=0.5.6,>=0.4.6' distribution was not found and is required by borgbackup


Additional info:
* package version(s):
> pacman -Q borg python-msgpack
borg 1.1.7-1
python-msgpack 0.5.6-2

Steps to reproduce:
Install borg via pacman on vanilla x86_64 or ARM machine, run borg and above error will appear.


I was able to manually fix the issue by editing the file /usr/lib/python3.7/site-packages/borgbackup-1.1.7-py3.7.egg-info/requires.txt and changing the first line from:

msgpack-python!=0.5.0,!=0.5.1,!=0.5.2,!=0.5.3,!=0.5.4,!=0.5.5,<=0.5.6,>=0.4.6

to:

msgpack!=0.5.0,!=0.5.1,!=0.5.2,!=0.5.3,!=0.5.4,!=0.5.5,<=0.5.6,>=0.4.6

As the python package installed from python-msgpack is just named "msgpack" in python. Borg runs fine after making this change.
Comment by daniele arosio (darosio) - Tuesday, 02 October 2018, 06:20 GMT
Same issue!
I temporarily fixed it with:

>> pip install msgpack-python==0.5.6 --user
Comment by Alcasa MZ (alcasa) - Tuesday, 02 October 2018, 08:40 GMT
Some msgpack-related patches seem to have been removed since 1.1.6 by the maintainer. Downgrading borgbackup to 1.1.6-3 will also work as a temporary fix.
Comment by Gunnar Krüger (Taijian) - Tuesday, 02 October 2018, 09:18 GMT
can confirm that the workaround proposed by @Mark works for me, too!
Comment by mrfaber (mrfaber) - Tuesday, 02 October 2018, 23:51 GMT
Eli, can you sed out the msgpack-python line in setup.py at least until borg v1.2 is released?
I know it's a PITA to argue with the upstream maintainers and they will not fix this for now, see https://github.com/borgbackup/borg/pull/3891.
Comment by Eli Schwartz (eschwartz) - Wednesday, 03 October 2018, 02:28 GMT
Yikes. There's a reason I listed the initial patch via the pull request link, because it wasn't actually accepted upstream!

It therefore should not be removed with the new release of borgbackup...

Loading...