Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60239 - [systemd] doesn't build

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Saturday, 29 September 2018, 07:30 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 29 October 2018, 02:33 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

The Meson build system
Version: 0.48.0
Source dir: /data/INSTALL/systemd/src/systemd-stable
Build dir: /data/INSTALL/systemd/src/build
Build type: native build

meson_options.txt:49:0: ERROR: Option name debug is reserved.

A full log can be found at /data/INSTALL/systemd/src/build/meson-logs/meson-log.txt

Seems others hit it too, see Debian:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=909455
https://salsa.debian.org/systemd-team/systemd/commit/28210e596a3c477a411adde2f092826f03a972ff

Additional info:
* package version(s): 239.2-2


Steps to reproduce:

asp export systemd
cd systemd
staging-x86_64-build
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 29 October 2018, 02:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  systemd 239.6-1
Comment by Andreas Baumann (andreas_baumann) - Saturday, 29 September 2018, 07:34 GMT
The patch changes the options of meson to fit to systemd. This seems wrong as I don't know
how many packages depend on meson in it's current state.
Comment by Andreas Baumann (andreas_baumann) - Saturday, 29 September 2018, 08:17 GMT
Ah. I misread the patch: it's basically moving the systemd debug option out of the way as
meson added a debug flag. So the patch is fine. :-)
Comment by Andreas Baumann (andreas_baumann) - Saturday, 29 September 2018, 08:29 GMT Comment by loqs (loqs) - Saturday, 29 September 2018, 12:04 GMT Comment by Christian Rebischke (Shibumi) - Tuesday, 02 October 2018, 10:19 GMT
Hi,
can we get this fixed? I need it for compiling systemd for fixing another bug and debugging some issues.
When I tried to apply the patch, I get something like this:

patching file rules/50-udev-default.rules.in
patching file sysusers.d/basic.conf.in
patching file meson.build
Hunk #1 FAILED at 765.
1 out of 1 hunk FAILED -- saving rejects to file meson.build.rej
patching file meson_options.txt
Hunk #1 FAILED at 46.
1 out of 1 hunk FAILED -- saving rejects to file meson_options.txt.rej


Comment by Andreas Baumann (andreas_baumann) - Tuesday, 02 October 2018, 11:48 GMT Comment by Andreas Baumann (andreas_baumann) - Tuesday, 02 October 2018, 13:34 GMT
Ignore the tests when you are building systemd, one check is currently failing:

234/315 test-compress FAIL 1.21 s (killed by signal 6 SIGABRT)

./test-compress fails in an assertion:

Assertion 'r < 0' failed at ../systemd-stable/src/journal/test-compress.c:235, function test_lz4_decompress_partial(). Aborting.
Abort (core dumped)
Comment by loqs (loqs) - Tuesday, 02 October 2018, 17:33 GMT
Test failure appears to be due to https://github.com/lz4/lz4/commit/f9725fdc46cc96c49d3cf3905a3b084b27151f33 building with lz4 1:1.8.2.2 or the commit previous to that merge succeed.
Comment by loqs (loqs) - Thursday, 04 October 2018, 17:18 GMT
https://github.com/systemd/systemd/issues/10259
Edit:
Compatibility patch require lz4 >= 1.8.3 and ensure the test passes.

Loading...