Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60220 - [dsdp] certificate error on source download

Attached to Project: Community Packages
Opened by Erich Eckner (deepthought) - Thursday, 27 September 2018, 16:24 GMT
Last edited by Andrzej Giniewicz (Giniu) - Saturday, 20 October 2018, 13:35 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Andrzej Giniewicz (Giniu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

==> Making package: dsdp 5.8-2 (Do 27 Sep 2018 18:23:16 CEST)
==> Retrieving sources...
-> Downloading DSDP5.8.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 178 100 178 0 0 437 0 --:--:-- --:--:-- --:--:-- 437
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here: https://curl.haxx.se/docs/sslcerts.html

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.
==> ERROR: Failure while downloading http://www.mcs.anl.gov/hs/software/DSDP/DSDP5.8.tar.gz
Aborting...

Additional info:
* package version(s)
dsdp 5.8-2 (git revision 7203130af3106e5b8c3df2f9f1b093fc69c673ea)

Steps to reproduce:
> git checkout 7203130af3106e5b8c3df2f9f1b093fc69c673ea
> cd dsdp/repos/community-x86_64
> makepkg --verifysource
This task depends upon

Closed by  Andrzej Giniewicz (Giniu)
Saturday, 20 October 2018, 13:35 GMT
Reason for closing:  Works for me
Comment by loqs (loqs) - Thursday, 27 September 2018, 18:49 GMT
https://www.mcs.anl.gov is not bundling the certificate
Entrust Certification Authority - L1K
Fingerprint SHA256: 13efb39a2f6654e8c67bd04f4c6d4c90cd6cab5091bcedc73787f6b77d3d3fe7
Required as the intermediate for
Entrust Root Certification Authority - G2
Fingerprint SHA256: 43df5774b03e7fef5fe40d931a7bedf1bb2e6b42738c4e6d3841103d3aa7f339
Comment by Andrzej Giniewicz (Giniu) - Saturday, 20 October 2018, 13:35 GMT
Works for me now, possible upstream fixed server configuration? I'm closing as worksforme, reopen if it is still an issue.

Loading...