Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60212 - [FFMPEG] ffmpeg package in 'extra' without avresample

Attached to Project: Arch Linux
Opened by Vladimir (_v_l) - Thursday, 27 September 2018, 01:11 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 27 September 2018, 01:25 GMT
Task Type Support Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

With changes "2018-08-27 libavresample drop: ffmpeg 1:4.0.2-3" (https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/ffmpeg&id=a0f9a95b804d34209c88122fe9941179ad584262) the 'libavresample' was removed from FFMPEG package without clear explanation why this was done. This change "breaks" freerdp build from git repository (I do this on my own) when the freerdp is build with -DWITH_FFMPEG=ON.

I searched a little the Internet but didn't find what could be wrong with 'libavresample', so why it was dropped?

---
WBR, Vladimir Lomov

This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 27 September 2018, 01:25 GMT
Reason for closing:  Not a bug
Additional comments about closing:  https://www.archlinux.org/todo/libavresa mple-drop/ and yes, it's very bad indeed.
Comment by loqs (loqs) - Thursday, 27 September 2018, 01:15 GMT Comment by Vladimir (_v_l) - Thursday, 27 September 2018, 01:17 GMT
Sorry, my fault, now I see in git repository:

$ git log libavresample/
...
commit c29038f3041a4080342b2e333c1967d136749c0f
Author: Rostislav Pehlivanov <atomnuker@gmail.com>
Date: Mon Dec 25 02:05:52 2017 +0000

lavr: deprecate the entire library

Deprecate the entire library. Merged years ago to provide compatibility
with Libav, it remained unmaintained by the FFmpeg project and duplicated
functionality provided by libswresample.

In order to improve consistency and reduce attack surface, as well as to ease
burden on maintainers, it has been deprecated. Users of this library are asked
to migrate to libswresample, which, as well as providing more functionality,
is faster and has higher accuracy.

Signed-off-by: Rostislav Pehlivanov <atomnuker@gmail.com>

Please add the link to the commit and the topic "lavr: deprecate the entire library" on next ffmpeg package update.

Loading...