Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60169 - isync: imaps connection to googlemail fails

Attached to Project: Community Packages
Opened by Oliver Mangold (omangold) - Sunday, 23 September 2018, 09:32 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 23 September 2018, 15:01 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Since around Sep, 18-19, 2018, mbsync refuses to work with imap.googlemail.com, producing errors like this, when TLS is set to v1.2:

SSL error connecting imap.googlemail.com ([2a00:1450:4013:c04::10]:993): self signed certificate

It seems to be caused by Google having enabled SNI (see links below).

Additional info:

* package version(s)

1.3.0-1

* config and/or log files etc.

--- .mbsyncrc -----------------:
...
IMAPAccount ....
Host imap.googlemail.com
User ...
PassCmd ...
SSLType IMAPS
SSLVersions TLSv1.2
...
-------------------------

Steps to reproduce:

- Create a config with an Google imap account like above
- Run mbsync <accountname>

More info:

The issue seems to be fixed upstream. See:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906955
https://sourceforge.net/p/isync/isync/ci/17babc1695e82ca80d032b79e920fcb86ede2347/
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 23 September 2018, 15:01 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#60077  and update your system first
Comment by loqs (loqs) - Sunday, 23 September 2018, 10:03 GMT

Loading...