Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60148 - [spectacle] Missing dependency qt5-quickcontrols

Attached to Project: Arch Linux
Opened by Fedor Piecka (piecka) - Friday, 21 September 2018, 12:32 GMT
Last edited by Antonio Rojas (arojas) - Friday, 21 September 2018, 20:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: When trying to take a screenshot of a rectangular region, segmentation fault occurs because of a missing QtQuick.Controls module.


Additional info:
$ pacman -Q | grep specta
spectacle 18.08.1-1
$ spectacle
qrc:/QuickEditor/EditorRoot.qml:23:1: module "QtQuick.Controls" is not installed
QObject::connect: Cannot connect (null)::acceptImage(int, int, int, int) to QuickEditor::acceptImageHandler(int, int, int, int)
QObject::connect: Cannot connect (null)::cancelImage() to QuickEditor::grabCancelled()
Segmentation fault (core dumped)


Steps to reproduce:
Run spectacle without the package qt5-quickcontrols installed, set the options the same as in the attached screenshot and click "Take a New Screenshot".
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 21 September 2018, 20:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  spectacle 18.08.1-2

Loading...