Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60130 - [mesa][libglvnd] The game Dying Light does not work with a standard Arch's package.

Attached to Project: Arch Linux
Opened by John (gee) - Thursday, 20 September 2018, 04:12 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 17 June 2019, 15:53 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Hello,

I've been looking for a while on how to get DL running on Arch and I finally found it.

Arch's default compiler flags are:

CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"

"-fno-plt" in C/CXXFLAGS and ",-z,now" in LDFLAGS need to be unset when compiling Mesa to get DL to not crash.

The other change required is to not use glvnd, with "-D glvnd=false". I tried building libglvnd with the same flags as Mesa, or none at all, but it didn't help.

The behavior is the same with Mesa 18.2.0 or Mesa-git, with LLVM 6.0 or master.
I haven't tried with autoconf though, only Meson, but I can try if you think it'd be helpful.

I've tried this on my 280X and another user's 580X, so I don't think it depends on the model. We're all on amdgpu.

I'd be happy to try / provide whatever would help.


Thank you!

Additional info:
* Current versions: Mesa 18.2.0, Linux 4.18.8, GCC 8.2.1, glibc 2.28, but it failed in previous ones too.
* I don't have any helpful log, as the game segfaults without these, a backtrace in gdb doesn't show me anything useful, and there's nothing in dmesg.
* I've reported that to upstream, but it was suggested to report it here instead, as Arch is applying non default FLAGS.


Steps to reproduce:
- Run Dying Light with standard Arch Mesa from Steam
- Get the game to segfault
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 17 June 2019, 15:53 GMT
Reason for closing:  Upstream
Additional comments about closing:  There's nothing we can do here.
Comment by Laurent Carlier (lordheavy) - Monday, 17 June 2019, 06:33 GMT Comment by John (gee) - Monday, 17 June 2019, 06:55 GMT
This is more of a GLEW bug that can be fixed in Mesa than in libglvnd I believe.

Loading...