Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60116 - [lightdm-webkit-theme-litarvan] Installs the source code and not the compiled package.

Attached to Project: Community Packages
Opened by drew (slaqer) - Tuesday, 18 September 2018, 23:10 GMT
Last edited by Filipe Laíns (FFY00) - Thursday, 20 September 2018, 22:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Filipe Laíns (FFY00)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The PKGBUILD grabs the source code from https://github.com/Litarvan/lightdm-webkit-theme-litarvan/archive/v2.0.7.tar.gz and then extracts and installs it without ever executing the build script which uses https://www.dartlang.org/ to work. It should be grabbing from https://github.com/Litarvan/lightdm-webkit-theme-litarvan/releases/download/v2.0.7/lightdm-webkit-theme-litarvan-2.0.7.tar.gz instead as it is already compiled and won't need dart as a dependency to fix.

Additional info:

** (lightdm-webkit2-greeter:31106): WARNING **: 14:48:12.169: [ERROR] :: A problem was detected with the current theme. Falling back to default theme...


Steps to reproduce:

1. Install the lightdm-webkit-theme-litarvan package with the current PKGBUILD
2. Set /etc/lightdm/lightdm-webkit2-greeter.conf to use the litarvan theme
3. Run the lightdm-webkit2-greeter
This task depends upon

Closed by  Filipe Laíns (FFY00)
Thursday, 20 September 2018, 22:16 GMT
Reason for closing:  Fixed
Comment by Eli Schwartz (eschwartz) - Thursday, 20 September 2018, 04:44 GMT
No, we should build this from source just like every other package in our repos.
Comment by drew (slaqer) - Thursday, 20 September 2018, 21:23 GMT
My suggestion was based off this comment (https://github.com/Litarvan/lightdm-webkit-theme-litarvan/issues/24#issuecomment-411199821) in the issues section for the GitHub page. It looked to me as if the source was never intended to be used by anyone else other than the main dev, and that it would be best to use the compiled release version instead. I personally don't mind either way and will be content with any fix.
Comment by Filipe Laíns (FFY00) - Thursday, 20 September 2018, 22:16 GMT
Should be fixed now. I am using the prebuilt binaries temporarily, until the upstream manages to get it working with dart 2.0.0.

Loading...