Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60102 - [nvidia-utils] 2-Way NVIDIA SLI requires disabling Primary GPU option in xorg.conf.d

Attached to Project: Arch Linux
Opened by Nyameko Lisa (NLisa) - Tuesday, 18 September 2018, 07:58 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Sunday, 07 October 2018, 21:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Unable to get into graphical boot using 2-way SLI with NVIDIA GeForce 1080Ti's, gdm fails to launch xorg properly on accounts of no devices or screens found.

Requesting that the config file /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf be updated such as to exclude or unset the ""PrimaryGPU" "yes"" option unless, Bumblebee / Optimus are installed?


Additional info:

Related to Arch Forum Post https://bbs.archlinux.org/viewtopic.php?id=240359 and Ubuntu Launch Pad Bug Reports https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1752053 and https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1756226.

* package version(s)

xorg-server-1.20.1-1

nvidia 396.54-4

nvidia-settings 396.51-1

gdm 3.28.4-1

* config and/or log files etc.

In /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf

...

Section "OutputClass"
...
# Option "PrimaryGPU" "yes"


Steps to reproduce:

From fresh Arch deployment:
Install nvidia xorg gdm gnome and gnome-extra groups.
Enable gdm.
Reboot with 2 x GPUs and SLi bridge connected.
GDM does fails and cannot enter graphical boot.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Sunday, 07 October 2018, 21:20 GMT
Reason for closing:  Won't fix
Additional comments about closing:  See comments.
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 24 September 2018, 06:00 GMT
Alright, what I'll do is remove that line and for bumblebee install a new file that overrides this one.
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 24 September 2018, 06:48 GMT
Alright test rel -2 in testing.
Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 27 September 2018, 04:54 GMT
Does it work ok for you?
Comment by Nyameko Lisa (NLisa) - Thursday, 27 September 2018, 08:51 GMT
Hi Sven, Sorry for the delay in getting back to you. Yes, this change works for me (nvidia 410.57-2, nvidia-utils 410-57.2, nvidia-settings 410.57-2) on my 2xSLI GPU machine.

Will test Bumblebee GPU switching configurationon my laptop tonight or tomorrow night.

Also, I don't know if this change may break nvidia-dkms now...? [url=https://bbs.archlinux.org/viewtopic.php?id=240695]Testing Repo Subforum NVIDIA 410[/url].

Thanks,
Comment by David Roth (V1del) - Saturday, 29 September 2018, 15:50 GMT
This will/does break Optimus setups, and this file was originally added to fix Optimus setups. It also just works on single card configurations. Maybe a better option would be to split that config into a nvidia-optimus-support / nvidia-prime-support package? Afaik the bumblebee package already does relevant overrides and it worked like that. However that snippet was for the PRIME case without Bumblebee
Comment by Maksim (barlog) - Saturday, 29 September 2018, 20:40 GMT
Without that record on notebook NVidia does not enabled. And secondary monitor does not working. And it is not so easy to find cause.
Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 30 September 2018, 03:06 GMT
Shouldn't the file override I added to bumblebee keep everything as it was for bumblebee users?
Comment by David Roth (V1del) - Sunday, 30 September 2018, 09:15 GMT
For bumblebee users yes, however the original file was added to ease usage of the PRIME setup without bumblebee. I.e. what's described in https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Using_nvidia

The xorg.conf there is technically optional (however I don't know if it would work already by simply having that xorg.conf or if the PrimaryGPU line is needed in any case) thanks to that drop in file. Now that it lacks the PrimaryGPU directive, it does not set up the necessary baseline anymore, and starting X will fail.
Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 30 September 2018, 10:04 GMT
I see. So we must not have that directive to support multi GPU but we need it to support PRIME multi GPU. How vexing. Now what would be the best course of action?
Comment by Nyameko Lisa (NLisa) - Monday, 01 October 2018, 08:00 GMT
I believe the best course of action would be to leave the original file as is with the PrimaryGPU directive included.

Multi GPU SLI is "probably" rarer and more esoteric than Multi GPU Laptop configurations.

Should there be anyone else that wants to setup an SLI configuration, they should be able to find it in the amended wiki page: https://wiki.archlinux.org/index.php/NVIDIA/Tips_and_tricks#Enabling_SLI,

So I would recommend the change to be reverted, and this bug closed...?
Comment by David Roth (V1del) - Monday, 01 October 2018, 12:25 GMT
Imo there are three options:

1. Split the config snippet into an additional package (like e.g. pulseaudio-alsa) called nvidia-optimus-support or similar that the utils packages can optdepend on. Is of course an additional thing to maintain, so that's your call.
2. Revert to the previous file, as laptops and people using PRIME are likely to be more prevalent than SLI setups (and from what I'm gathering with Vulkan and co. SLI setups in general are on their way out)
3. Don't ship any config at all, redirect people relevantly to the corresponding wiki articles for setup.

Options 1. 3. will likely result in a short support influx due to people relying on the current behaviour, but that is likely to be handleable (or maybe add a news snippet about it in case)
Comment by David Roth (V1del) - Wednesday, 03 October 2018, 10:46 GMT
Related reports: 60259, 60245

Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 04 October 2018, 22:51 GMT
I decided to revert the recent changes and instead make add a visible mention about SLI stuff in the wiki: https://wiki.archlinux.org/index.php/NVIDIA#Multiple_GPUs.2FSLI

The changes broke more setups than it fixed. I also don't want to add an additional package to fix stuff for SLI users as that further complicates things and we already have plenty of NVIDIA packages. I think the documentation way is probably the best course of action here.

I'll leave this report open for a few more days.
Comment by David Roth (V1del) - Friday, 05 October 2018, 10:57 GMT
Yes I'd have to agree, that setup is far more common, and SLI config will have to explicitly set up a configuration either way, so making the note there is more likely to have people stumble over it.

Loading...