Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60080 - [gnutls] libidn dependency is not required

Attached to Project: Arch Linux
Opened by nl6720 (nl6720) - Sunday, 16 September 2018, 16:56 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 16 September 2018, 18:40 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
gnutls is explicitly built without IDN with the option "--without-idn" ( https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/gnutls&id=879905f953d581b9b781acd4d6acd07a850a6d79 ). When preparing gnutls 3.5.7 the libidn dependency was added back for some reason ( https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/gnutls&id=b9fbc7099b02e03e7d61ce31f888e8bf8c32285a ).

It looks like nothing in the package links against libidn, so the libidn dependency can be removed. If IDN functionality is desired the dependency could be changed to libidn2, since gnutls supports it.


Additional info:
* package version(s)
* config and/or log files etc.
gnutls 3.5.19-1


Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 16 September 2018, 18:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.5.19-2

Loading...