Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60071 - [libreoffice-fresh] offline help missing css files and js files for language pack use

Attached to Project: Arch Linux
Opened by Friedrich Strohmaier (bitsfritz) - Sunday, 16 September 2018, 00:12 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 16 September 2018, 15:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: since version 6.1 libreoffice offers offline help other than en_US language via webbrowser and local stored html files. It finally looks like
https://help.libreoffice.org/

archlinux libreoffice-fresh does not deliver necessary css and js files to make webcontent of offline help usable.

Additional info:
* package version(s)
libreoffice-fresh-6.1.0
libreoffice-fresh-6.1.1


* config and/or log files etc.
using midnightcommander URLS to show the place in the referring package..

content of help folder of Upstream Package:
LibreOffice_6.1.1_Linux_x86-64_deb.tar.gz/utar://LibreOffice_6.1.1.2_Linux_x86-64_deb/DEBS/libobasis6.1-core_6.1.1.2-2_amd64.deb/deb://CONTENTS/opt/libreoffice6.1/help

default.css
fuse.js
help.html
help.js
help2.js
hid2file.js
idxcaption.xsl
idxcontent.xsl
index.html
main_transform.xsl
media
normalize.css
paginathing.js

content of help folder of arch package:
libreoffice-fresh-6.1.1-1-x86_64.pkg.tar.xz/utar://usr/lib/libreoffice/help

en-US
idxcaption.xsl
idxcontent.xsl
main_transform.xsl


Steps to reproduce:
1. Install any language pack (here: libreoffice-fresh-de) via
pacman -S libreoffice-fresh-de
2. Open Libreoffice
3. Configure the userface of your choosen language pack via
Tools -> Options -> Language Settings -> Languages -> User Interface
4. restart LibreOffice
5. Click (new language) <Help> -> <Libreoffice Help>
6. Browser starting
7. Not showing Help page?
7a. Enter URL file:///usr/lib/libreoffice/help/de/text/shared/main0108.html
8. Compare result with https://help.libreoffice.org/
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 16 September 2018, 15:03 GMT
Reason for closing:  Implemented
Additional comments about closing:  added new html based help system to 6.0.1-2

Loading...