Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60067 - [flatpak] allow successful build in more environments

Attached to Project: Arch Linux
Opened by Dor Askayo (xtor91) - Saturday, 15 September 2018, 17:06 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 15 September 2018, 17:07 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
While the package builds fine for some people, in my environment the build fails. It looks like an issue in the PKGBUILD; "-shared" is removed by sed. The following patch solves it:

--- a/PKGBUILD 2018-09-15 15:03:31.248153975 +0300
+++ b/PKGBUILD 2018-09-15 15:05:04.875429702 +0300
@@ -58,7 +58,7 @@ build() {
--with-priv-mode=setuid \
--with-dbus-config-dir=/usr/share/dbus-1/system.d

- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ sed -i -e 's/ -shared / -shared -Wl,-O1,--as-needed\0/g' libtool

make
}

It may have something to do with "-pie" (Position Independent Executable) being used by default, since specifying "-no-pie" seems to fix it as well.

Additional info:
* package version: 1.0.1 and 1.0.2 (testing)

Steps to reproduce:
1. Build using ABS.
2. Get this link failure:
...
CCLD libflatpak.la
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/Scrt1.o: in function _start': (.text+0x24): undefined reference tomain'
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:1880: libflatpak.la] Error 1
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 15 September 2018, 17:07 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#60065 

Loading...