Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60061 - [libdrm] latest version crashes blender using opencl-amd[AUR]

Attached to Project: Arch Linux
Opened by Chris Mowley (mowley) - Friday, 14 September 2018, 17:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Unconfirmed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 3
Private No

Details

Description:

The latest version of libdrm 2.4.94-1 causes blender to crash out with error

amdgpu_device_initialize: amdgpu_query_info(ACCEL_WORKING) failed (-9)

as soon as the user goes anywhere near OpenCL (system tab for instance)

downgrading to libdrm 1.93 solved the issue.

Will flag this upstream
This task depends upon

Comment by Chris Mowley (mowley) - Friday, 14 September 2018, 17:46 GMT
that should read downgrading to libdrm 2.4.93-1 solved the issue.
Comment by Chris Mowley (mowley) - Saturday, 15 September 2018, 00:11 GMT
also gpu compute hardware is AMD Radeon Pro WX-5100

using current version of opencl-amd[AUR]
Comment by Max (sku1d) - Wednesday, 19 September 2018, 22:33 GMT
I can confirm, that it only works with the earlier version. But that does not mean, that a system wide downgrade of libdrm is necessary.

Interestingly this works for me as a workaround:

cd /tmp
wget https://dri.freedesktop.org/libdrm/libdrm-2.4.93.tar.gz
tar xf libdrm-2.4.93.tar.gz
cd /tmp/libdrm-2.4.93
./configure
make
LD_PRELOAD=/tmp/libdrm-2.4.93/amdgpu/.libs/libdrm_amdgpu.so /bin/blender
Comment by Trever Grissam (Jhackler) - Saturday, 22 December 2018, 18:30 GMT
I use maxes method for now but use an actual folder on my computer and a shell script to launch blender with preload so when and if this issue is ever fixed I can just delete the script and the older libdrm
Comment by Chris Mowley (mowley) - Saturday, 22 December 2018, 22:09 GMT
The latest opencl-amd(AUR) package fixes this issue...
Comment by Chris Mowley (mowley) - Saturday, 22 December 2018, 22:10 GMT
Name : opencl-amd
Version : 18.50.708488-1

Name : libdrm
Version : 2.4.96-1
Comment by Andrew Shark (ashark) - Monday, 24 December 2018, 01:44 GMT
Have you tried it with opencl-amd of version 18.50?
Comment by Trever Grissam (Jhackler) - Wednesday, 26 December 2018, 08:25 GMT
I have now! I did not even realize system had failed to update after that version came out, it works like a charm now.

Loading...