Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60033 - [cups] lpr hangs; cups `631' page empty

Attached to Project: Arch Linux
Opened by Hans Pelleboer (hansp) - Wednesday, 12 September 2018, 19:13 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 12 April 2019, 09:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version 5.1.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info: On a functional, up-to-date system, with cups, most foomatic-db packages, hplip and avahi installed, I tried to print a small text file on a previously functional printer.
lpr responded, the task appeared in lpq, but never terminated, printer gave no output. On checking the cups administration pages, I discovered to my dismay,
that apart from the `start' page under local:631, all underlying pages were completely _empty_.


Steps to Reproduce:
All packages mentioned above have been removed, and re-installed multiple times, in different orders, all yielding the same result.
Cups.org did not mention any similar bugs, so to no avail. system-config-printer showed printer and allowed underlying parameters to be
changed.
Apart from a re-installation from scratch, my box of tricks is empty.
N.B. My office is by and large paperless, this printer is used about ten times a year; this may very well be the result of
a system update, albeit not necessarily the most recent one.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 12 April 2019, 09:33 GMT
Reason for closing:  No response
Comment by Eli Schwartz (eschwartz) - Wednesday, 12 September 2018, 19:15 GMT
  • Field changed: Attached to Project (Pacman → Arch Linux)
  • Field changed: Summary (lpr hangs; cups `631' page empty → [cups] lpr hangs; cups `631' page empty)
And this is a pacman bug because why?
Comment by loqs (loqs) - Wednesday, 12 September 2018, 20:39 GMT Comment by Hans Pelleboer (hansp) - Wednesday, 19 September 2018, 17:44 GMT
Update Sept. 19

Although Cups still presents the `empty screen' I have made some progress: The command within hp-setup to retrieve a key
failed initially; I lifted the command string from the screen, edited it and then ran the command successfully. Next I ran hp-setup as root without the -i flag -- the program complained about both! -- and managed to download a functional plugin from HP's website
(Not a particularly clean approach, I admit!).

As a consequence the printer finally produces some output; Lpq and lpstat enable sensible access. Localhost:631 pages
still empty, though, so no printer administration possible from within cups. But at least the cups-pdf filter works.

Comment by Andreas Radke (AndyRTR) - Wednesday, 30 January 2019, 13:14 GMT
What's the status? We had several updates related to these packages. The cups administration interface should be there even without any further driver pkg. The other issue seem hplip related where trouble with installing the plugin is known and even written down at the hplip plugin page with a workaround.

Loading...