Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60026 - [nano] Backspace behaviour

Attached to Project: Arch Linux
Opened by Sibren Vasse (SibrenVasse) - Tuesday, 11 September 2018, 21:04 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 12 September 2018, 19:23 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Since 3.0-1, backspace seems bound to the 'cutwordleft' command (similar to 'db' in vim).
I'm using termite as a terminal emulator, the same happens in kitty, but not in xfce4-terminal.
Old behaviour is observed when $TERM is changed from xterm-termite to 'xterm'.

Additional info:
nano 3.0-1
termite 13-3
termite-terminfo 13-3
kitty 0.12.1-1
xfce4-terminal 0.8.7.4-1

Steps to reproduce:
1 Open file
2 Type word
3 Press backspace

Expected behaviour: delete character left of cursor
Observed behaviour: delete all characters from the cursor position to the beginning of the preceding word
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 12 September 2018, 19:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.0-2
Comment by loqs (loqs) - Tuesday, 11 September 2018, 23:04 GMT
http://git.savannah.gnu.org/cgit/nano.git/commit/?id=e6429e782a09092eb87305d5d4cd2831c7129ad7 or
http://git.savannah.gnu.org/cgit/nano.git/commit/?id=33fb54c75fb7a11c8484edaacfcedff1d4c199ba
seem the most likely causes to me the following are related but I do not think would be the cause.
http://git.savannah.gnu.org/cgit/nano.git/commit/?id=571676eb853449e5782cbd0d7e080b01e4516e78
http://git.savannah.gnu.org/cgit/nano.git/commit/?id=a67f6c60317dc72b632ba2e8990248205510e6d6
http://git.savannah.gnu.org/cgit/nano.git/commit/?id=d04c8f88f1e640d5528dc8cb83c50a79b27b7500
Can you build nano-git and try reverting the the first commit I suggest see if that is the cause,
if not undo the revert and try the second commit instead, if that fails I would suggest bisecting to find the cause.
Comment by Sibren Vasse (SibrenVasse) - Tuesday, 11 September 2018, 23:22 GMT
Reverting e6429e782a09092eb87305d5d4cd2831c7129ad7 fixes the issue.

Upstream bug: https://savannah.gnu.org/bugs/?54642
Comment by Andreas Radke (AndyRTR) - Wednesday, 12 September 2018, 05:54 GMT
Upstream is already aware of this. Let's wait for the proper fix.

https://lists.gnu.org/archive/html/nano-devel/2018-09/msg00030.html

Loading...