Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60024 - [vlc] transport stream no longer works

Attached to Project: Arch Linux
Opened by Tim (foggybrain) - Tuesday, 11 September 2018, 19:04 GMT
Last edited by Levente Polyak (anthraxx) - Tuesday, 25 September 2018, 19:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

VlC and applications such as kaffeine and me-tv that use vlc can't display video and audio for dvb-t since upgrade from version 3.0.3.r1-2. Reverting back to version 3.0.3.r1-2 fixes problem. I have also been told that the vlc nightly build (manjaro) has fixed this problem.

This task depends upon

Closed by  Levente Polyak (anthraxx)
Tuesday, 25 September 2018, 19:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.0.4-4
Comment by loqs (loqs) - Tuesday, 11 September 2018, 20:39 GMT
Was the package aribb24 installed when the issue occurred?
Comment by Tim (foggybrain) - Tuesday, 11 September 2018, 20:47 GMT
I am using up to date manjaro kde and pacman -Q says aribb24 not installed, so no
Comment by Tim (foggybrain) - Tuesday, 11 September 2018, 20:51 GMT Comment by Antonio Rojas (arojas) - Wednesday, 12 September 2018, 06:17 GMT
> pacman -Q says aribb24 not installed, so no

and does it work if you install it?
Comment by Tim (foggybrain) - Wednesday, 12 September 2018, 09:33 GMT
Yes, after installation of aribb24 version 3.0.4-1 nosw works correctly with dvb-t in vlc, me-tv and kaffeine. I guess it needs to be added as a dependancy to vlc ?
Thank-you for your help.
Comment by Antonio Rojas (arojas) - Wednesday, 12 September 2018, 09:42 GMT
Building against aribb24 makes the transport stream plugin libts_plugin.so link against it, so many things are broken if it's not installed.
Comment by Tomasz M. Nowak (tmn505) - Wednesday, 12 September 2018, 19:07 GMT
I can confirm, that installing aribb24 solved the issue, on pure Arch Linux.
So +1 for adding it as dependency.
Comment by patrick (potomac) - Thursday, 13 September 2018, 17:55 GMT
maybe aribb24 should be a mandatory dependency for vlc and kaffeine ?
Comment by Doug Newgard (Scimmia) - Saturday, 15 September 2018, 13:19 GMT
So the problem here is only the description of the optional dep.
Comment by Levente Polyak (anthraxx) - Saturday, 15 September 2018, 13:53 GMT
@Scimmia: possibly, or possibly just make an exclusion from plugins being purely optdepends and assume network usage in any means (which transport stream plugin is) is assumed as general functionallity as thats required for anything but local file plyaback. will come up with a decision in the following days but tend to assume this special case should be a depends (not dvb-t related but transport stream in general)
Comment by Rémy Oudompheng (remyoudompheng) - Monday, 24 September 2018, 19:48 GMT
I do agree that either aribb24 should become mandatory (just like libdvbpsi) or be clearly mentioned as being mandatory for MPEG-TS.
I just spent a few days understanding why I couldn't use DVB anymore.
Comment by Max (thearchlinuxuser) - Monday, 24 September 2018, 20:05 GMT
Thank you guys for pointing out that aribb24 solves this issue. I even opened a bug in the VLC bug tracker because I thought it was their fault (worked in VLC player 3.0.3 but did not work anymore in 3.0.4).

I'm curious: why does installing aribb24 enable the ts plugin? The package file list does not contain it.
Comment by patrick (potomac) - Monday, 24 September 2018, 20:39 GMT
@Max: the archlinux packager has compiled vlc with the option "--enable-aribsub" since vlc 3.0.4 :

https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/vlc
https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/vlc&id=35d0cb5cdfbeed6e26b7b2379834be0823847edd

the "aribsub" feature requires the installation of aribb24 lib, and it seems that the DVB and transport stream features need now the aribb24 lib if the "--enable-aribsub" option has been used during the compilation of VLC,

one solution would be to recompile vlc without the option "--enable-aribsub", or make mandatory "aribb24" package if the packager wants to use "--enable-aribsub"

Loading...